MKV freeze bug revealed/explained


#1

I have been playing around with the Live for 3 weeks now, with absolute no freezing problems so far, just a couple of issues with subtitles. I have converted two Blurays with no problems with Handbrake, each yielding a file a around 5GB.

Today it was time for my 3rd Bluray, which yielded a file at around 10GB. Added a JPG and the subs as a SUB and IDX file (externally), 4 four files totally and went to watch the movie.

Bad luck … freezing problems after around 30 secs of watching (jerking with 1-2 pictures/sec, no sound). Restarting gave same effect, anywhere in the movie.

Tried two different HDs, and via network share (cabled), exactly same behaviour. Reset the Live, both ways, power cycling, downgraded to 1.01.24 … same result whatsoever. Almost giving up. So far, converted about 60 DVDs, and then it can’t play BD (which was my primary reason for buying it.  (Screaming out loud …)

But, wondering why some people have absolutely no problems, I tried as a last resort to remove the SUB and IDX file – and voila, the movie plays perfectly! Reapplying the files gave freezing immediately. This is 100% reproducible.

Trying now to mux the subs into the MKV file (and hopefully it works) …, I’ll then have to find a way to deal with a (hopefully non-distracting) transparency issue. Might even consider reupgrading to 1.02.21 …

Edit: Finished muxing … it plays perfectly (and for this movie the subs are not transparent).

But please, please, please, WD, fix that transparency bug soon …

Cocovanna


#2

Hmmmm.   This sort of makes sense.   Playing a high-bit rate file, and trying to access other files at the same time.  The WDTV probably doesn’t have enough buffer space to keep playing at such a high bit rate while it’s accessing others.

Interesting!