Miracast not working

#21

I am running on Stock ROM on both my devices

#22

thank you for the clarification  :smiley:    p.s. i responded to your PM

#23

Ok, finally got my hands on a WDTV Media Player *New Model*  (not the SMP)

Now, contrary to what i said about having the ethernet cable in at the same time you’re using “miracast” which is Wi-Fi…

You can have the ethernet cable plugged in and miracast will still work… i’m guessing, it switches to wireless mode when using miracast and then when finished… reverts back to wired connection.

When my Wi-Fi signal is weak (on either the Tablet or WDTV) … then the miracast handshake doesen’t work.

So, here’s a pic of it working with my Pipo M9 tablet :smiley:

Miracast
#24

I seem to have found a workaround to the miracast connection issue. It seems no matter what I do, I can’t connect my phone to my WDTV Live SMP, it gives the poor connection error.  But, if I launch Netflix on my phone, start a show, then enable screensharing on my phone, it works.  After that, I can go into any app, homescreen, whatever.

For some reason, I have to be watching a show on Netflix in order for screen sharing to start working.  Try it out.  I’m using a Galaxy Note 3, stock rom.

#25

I have it working on my Note 2 N7100 running Dr.Ketans 10.1 rom,

I use Wired LAN for internett on the WD and it is working fine.

The only issue is if I disconnect, I have to reboot the WD to reconnect.

#26

i have same issue on my nexus 7 2013 (wifi). 

and i found out what the problem is. It is not the WD TV Live or android device. 

it’s because of “roms” i use. i used to use Slim rom (4.4 Kitkat) and i coudn’t cast anything due to poor connection(?).

But when i change rom to CM11 M9 (kitkat) it cast with no problem.

I think some roms still have a problem with miracast.

So i recommend you changing rom if you need to use miracast.

#27

Reading this thread helped me get it working on my wife’s HP Slatebook X2, but not on my Galaxy S4.

The remark about Miracast working only over wifi made me realize that the wifi connection stored in the box was no longer valid as I long time ago changed the SSID of my wifi, but since the box is cabled it didn’t matter until now.

So I entered setup and selected Wireless connection instead with the updated wifi info. Then Miracast worked on the tablet, but alas, not on my phone.

Furthermore, I can confirm that running the box cabled is no problem to Miracast as it will automatically change to WIFI mode. But of course, the stored wifi info has to be correct. So I do get the best of two worlds! Note: it is a bit more difficult to start a cabled connection as I have to try two or three times. But then it works fine.

As said, my S4 will not connect. However, I can make a Wifi Direct connection to the WD TV Live with it  - I just have no idea what Wifi Direct is good for!

#28

I too have been troubleshooting “Screen Mirroring” from my Samsung Galaxy S4 to a WD TV Live Streaming device, as was made available in the last Fireware update.

When I initiate the connection from my S4, it usually fails.

Error messages as follows:

On WDTV
Wireless Display Disconnected
The wireless display connection was disconnected unexpectedly due to a poor connection. Please check your wireless connection and try again.

On Galaxy S4
Screen Mirroring
Failed to connect via Screen Mirroring

However, it will connect successfully about once every 30 times. When it’s working, it works great. Video + Audio. Just what you’d expect.

I’ll know it’s going to work when the upload/download blinking arrows on my S4’s WiFi icon are both solid “on”, instead of blinking. Any blinking and it’s a sure bet the connection will fail.

Note that I run my WDTV over wired ethernet, and it has had Screen Mirroring successfully connect. I have also run my WDTV over wireless (as an experiment), and that too has had Screen Mirroring successfully connect.

I usually run wired.

I’ve tried holding my S4 in various ways, but the success rate doesn’t seem to improve, no matter what I do.

Then I stumbled upon an app from Google Play:

“Wifi Display (Miracast) Helper” by ppgirl.

For whatever reason, my success rate is now about 2 out of 3. What I mean by that is by initiating the Screen Mirroring via this app, it will connect most of the time. Sometimes it still fails with the error message as I posted above, but most of the time it connects fine.

I don’t know what the reason is, but it’s an improvement - enough that Miracast is potentially useful.

Hope that helps someone!

Cheers

#29

I am having this issue when trying to connect my BlackBerry Z30. The very first time I tried to mirrior my Z30 screen it worked flawlessly. Each time after that I have tried it does not want to work. I get the following message on my WDTV:

“The wireless display connection was disconnected unexpectedly due to a poor connection. Please check your wireless connection and try again.”

The WDTV Live can see my BlackBerry as it shows the name of the device on the TV screen. But the arrow just spins and spins and it never connects.

On my Z30, the attempt to connect to the WDTV Live gives me this:

“Unable to scan: To discover other miracast devices that you can play on, disconnect from the miracast device that you are currently connected to.”

The funny thing is, I am not connected to any miracast device.

I am using a DLINK DIR-655 router and my wirless connection to the router with my Z30 and WDTV Live is perfect.

TO the poster above me that said they found a work-around using the “play-on” option, that does not use Miracast. Play-on uses DLNA. If you want to mirrior the screen of your smartphone or tablet onto your TV then you will need Miracast to work. At least this is what I have come to understand basedon all the reading I have done on this topic.

I hope WD is working a firmware revision for this issue as it seems to be impacting numerous devices… meaning the issue must lie with them as they are the common denominator.

#30

have you tried paulove’s suggestion above ?

Quote: The only issue is if I disconnect, I have to reboot the WD to reconnect

I have the same issue … connects 1st time no probs, but after disconnecting miracast i have to reboot the WDTV to connect again.

#31

I have not tried paulove’s suggestion yet. It seems very impractical to have to reboot (I assume he means reset the device by pushing the reset button on the back for 4 seconds?). Rebooting resets the factory configuration which is a PITA.

This is a very stange issue, as fellow Z30 owners on Crackberry are running the same setup as me and have no issues connecting. I’m banging my head against the wall trying to figure out what is off about my setup.

#32

Update: I reset the box and setup everything from scratch. Miricast seems to be working consistently now. I tried screen sharing 6 times, and all 6 connected. I turned off the WD and back on as a test. No issue yet. I’ll report back again if there are any further issues.

#33

I had the same problem with my Nexus 4 phone running Android 4.4.4. I reset the WD TT Live and now it works, both with WiFi and ethernet.

My Nexus 7 2012 with Android 5.0 doesn’t even detect the device though.

#34

the only way i can get it to work is by restarting my wd, when my devices will connect to them… which is frustrating! i shouldn’t have to restart my device to use it… i have 5 wd’s in my house it gets annoying, but that is the only way i can get it to connect! i have an s4 and a galaxy note 2013

hope this helps if any one has a better solution, please share

#35

I own a WDTV Live, with UTP cable connected. From my cheapo Lifetab Android Tablet, Miracast works fine. I just had to restart my WDTV once, but no problems till now.

A great aspect is, I can stream Spotify directly from my tablet to my surround receiver, which is connected with an optical cable to my WDTV.No need for the TV on! And the Android interface for Spotify is much better then the WDTV interface! Much faster, a keyboard for searching, radio function and very stabile! 

Thanks to Miracast I am in Audiophile Heaven now! :slight_smile:

#36

Hi, Have tried many times with some devices. Very strange. WD should release a new firmware to correct this. Something is wrong with miracast on this firmware.

1 Samsung Galaxy s4 gt-i9505 - NEVER get connected

2 Samsung Galaxy s4 gt-i9515 - Can connect. (sometimes not. Get the message falied to connect due to poor connection on wdtv, and on smartphone connection failed)

3 Samsung galaxy Tab T530 - NEVER get connected

Tried this with 2 different WDTV live Streaming. The results are the same. Both of course , with last firmware update. (the only that have miracast)

Notes: It’s impossible that i have poor connections. on both rooms, i have wdtv connected by cable side by side on the router, and the smartphone at a maxumum distance of 1m to the router. What can i do?

#37

If you are connected to guest mode with isolation, then I think you will have trouble connecting.

#38

Hi, of course i m not at guest network. I think that would never work.

I m at my normal wi fi network.

Smartphone recognizes wdtv and vice versa, but always i get error. Except for that model i said previous post.

#39

Western Digital, if you’re listening… please release a fix for Miracast on WD TV.

I’m editing this post. After previously having no trouble, I’m now in the same boat as others and having trouble and can’t use Miracast. Even though Wi-Fi Direct still works, when playing music on my phone for example, I can use wi-fi direct every time with the WD TV no problem. But Screen mirroring via Miracast is not working at all for me anymore. I can see the WDTV listed on my phone, but it just gets stuck on “connecting…” and the eventually fails. Powering off and on doesn’t fix it. I have not tried a factory reset, but why should I? Any “feature” that needs a factory reset to work, is broken. Factory resets are a PITA.

I guess I will need to do the “factory reset fix” on the WD TV to get it back, but how long before it fails again.

Miracast should work as advertised. No new patches from WD for months. Not a good look.

#40

And one more thing… wi-fi direct is an awesome way to send music on your phone to your home thearte system.  My WD TV is connected by HDMI to my TV, and my TV has optical audio out to my hi-fi amp, and the sounds is crystal clear… digital all the way.

Wi-fi Direct is great. It’s just a pity that screen mirroring and miracast are so buggy on the WD TV.  A fix, patch, update, firmware release would be great. Miracast on the WD TV should work as advertised. Anything less is not cool. If I need to factory reset the WD TV to get a feature working, it’s broken.