Messed up My Cloud file system when trying to install OMV

Hi folks!
I have successfully installed OMV on multiple WDMC Gen2, but I badly failed at a Gen1 device. That’s what I did:

  • Followed the guide on the famous OMV Google drive to install OMV 2
  • Tried upgrading which did not work
  • Tried installing a clean Debian the same way which obviously does not work.

There were some ugly error messages about /dev/md1 not being found etc (they disappeared so I could not copy paste them here). I do not dare rebooting the device as I am pretty sure it won’t boot. I still can access the device via SSH. How can I re-install a properly booting OS? (I don’t mind if it is WD’s original firmware, clean Debian or OMV), something where I can start from scratch.

Any suggestions? Thanks in advance!

See output of df:

root@MyCloud:~# df -h
Filesystem      Size  Used Avail Use% Mounted on
/dev/root       1.9G  1.7G  115M  94% /
tmpfs            23M  196K   23M   1% /run
tmpfs           5.0M     0  5.0M   0% /run/lock
tmpfs            10M     0   10M   0% /dev
tmpfs            46M     0   46M   0% /run/shm
tmpfs           114M   20K  114M   1% /tmp
/dev/sda4       3.6T  3.4T  125G  97% /mnt

See output of parted:
root@MyCloud:~# parted -l
Model: ATA WDC WD40EFRX-68W (scsi)
Disk /dev/sda: 4001GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt

Number  Start   End     Size    File system  Name     Flags
 3      15.7MB  528MB   513MB                primary
 1      528MB   2576MB  2048MB  ext3         primary  raid
 2      2576MB  4624MB  2048MB  ext3         primary  raid
 5      4624MB  4724MB  99.6MB               primary
 6      4724MB  4824MB  101MB                primary
 7      4824MB  4826MB  1049kB               primary
 8      4826MB  4828MB  2097kB               primary
 4      4828MB  4001GB  3996GB  ext4         primary


Model: Linux Software RAID Array (md)
Disk /dev/md0: 2048MB
Sector size (logical/physical): 512B/4096B
Partition Table: loop

Number  Start  End     Size    File system  Flags
 1      0.00B  2048MB  2048MB  ext3

I just realized I had another Gen1 device lying around. I wonder if it would be enough to just dd all partitions except sda4? Any ideas?

One can use any of the various unbrick methods to unbrick their My Cloud. User Fox_Exe has one method that more than a few of us have used to fix issues with non booting My Clouds or when replacing the internal single My Cloud hard drive. You cannot use a first gen My Cloud firmware or image on a second gen My Cloud. The second gen uses different hardware and firmware.

FIrst gen: https://drive.google.com/file/d/0B_6OlQ_H0PxVbzZac0plbkZKeGM/view
Second gen: https://drive.google.com/file/d/0B_6OlQ_H0PxVQVhnLVJOdDZISUU/view