Menu navigation jumping after firmware update

Hi all,

although this issue has been posted before and marked as “solved”, I find that it isn’t.

Updating to the latest firmware has caused navigation in the menu on all levels (folders, settings, …) to jump. It appears that going one step down actually causes it to go several steps down. Same for going up.

This has already been described here: WD-TV-Live-Firmware-Causing-Menu-Folder-jumping

Here is a similar report: Navigation, Menu skips and jumps

The first thread is marked as solved. But the so-called solution is to roll-back to previous firmware. Not really a “solution”, is it. Mitigation or workaround, maybe. :cry:

Anybody else seeing this? Is WD support aware of the issue?

This was a problem with an earlier firmware, but the latest firmware does not have this problem (at least for most of us). What firmware version are you using? Did you try pressing the reset button on the WD box?

I haven’t see this in a long time, if resetting do not solve your issue, turn off the WD TV Live, disconnect the cables for more than 10 minutes and then reconnect all.