Media Library WdTV Live Compiling for ever........?

 I updated the firmware to the latest version yesterday. (1 09 10) yesterday.  Using iplayer later screen froze. No response from any button. Disconnected power.  Restart. All ok except “compiling media library” hangs for ever…hours.  It was fine before- would compile library from 160gb of film, photos and music from portable hard drive  no problem.  I’ve done reset etc etc no change at all.  All media is available through “files” option so no big deal.  I’ve even tried just putting 1cd on a usb stick -same result “compiling media library” just hangs for ever.  Any suggestions?  I had thought of going back to the previous version of the firmware but the files to download are compressed and I can’t extract them-what do I need…winarchiver cant do it.


Plug it into your PC, and see if the drive is marked as having errors (it will tell you when it’s discovered.)

If so, then let it repair the errors.

Then safely remove it from the PC and plug it back into the WD and see if the compile finishes.

If that does not correct it, then eject it and plug it into your PC again, and delete the hidden “.wdtv” folder which is in the root of the disk, then safely remove it and return it to the WD.

1 Like

Hi thanks for speedy reply…I’ve already done both of those things, no joy.  I’ve even copied a ripped a new cd and transferred it to a prviously unused USB pen drive.  Same result…turn on Media Library message comes up compiling media library …  very puzzling as it was fine before with any number of different pen drives and portable hard drives.  thanks again

Hmmm.  So you say you’ve done a RESET, but have you tried a RESTORE back to factory defaults?

Setup / System / Restore 

1 Like


yep I’m pretty sure I’ve done that too but I’ll try it again.



please keep us informed, if the reset helps. I have got the same problem since the new firmware using a NAS as shared network source.

I wrote several cases to the support. None has been answered yet. Don’t have so much hope they will answer…



Oh heck…I’ve just done a restore and now it wont even detect that anything is plugged in to either USB!

Panic over for now…I turned wdtv off disconnected everything left it two minutes reconnected and it found local storage…I’ve just turned media library back on to see if it’s made any difference…I’ll give it 1/2 hour.  I’ll keep you up to date with any changes (or not as case may be)

Still the same unfortunately…still at least I have acess to local storage restored…phew!

Is there any way to get back to the 1.8.X firmware? At least it worked then.

I also tried everything that has to do with Resetting the device / media library. Clearing the latter and switching it on/off. It is frustrating…

Yes you can download previous versions of the firmware…but they are compressed and I couldnt extract them!

Which URL did you use to download an archived version of the firmware?

Thanks in advance.

Got it and instructions at:,393/session/L3RpbWUvMTMzOTYxNDQ0NC9zaWQvOFMzWUJBLWs%3D

Hope it helps.

This could be a silly question, but have you check that the drive hasn’t got read-only protection box checked?

I have two boxes and both have no problem compiling the Media Library on 1.09.10 (they’re using the beta release)

I have a family member that ugraded to 1.09.10 through the New FW prompt (wireless) and his just compiled for ever.

not sure why this is happening or if there is a different between the two 1.09.10 FW’s (shouldn’t be) but rolling back and upgrading again fixed this for him.

it does seem very odd…can I ask how your family member extracted the previous version of the firmware…  As I said previously I downloaded them but couldn’t extract them…they weren’t recognised by anything I have.

all you do is unzip the file (

put the three files (wdtvlivegen3.bin, wdtvlivegen3.fff & wdtvlivegen3.ver) it creates into a thumb drive (make sure you don’t put it into a folder) then reboot the SMP.

nothing to it really.

hope that helps.

1 Like

Thanks for that but  how do you unzip the downloaded files…what do you use.  I downloaded them but couldnt extract/unzip them.

well you only need to unzip the one file you downloaded (

you can do that with winzip, winrar or any program that reads .zip files.

I downloaded winzip, extracted to a pen drive and stuck it in the front USB after start up.  It “upgraded” firmware to the previous version (oddly enough the screen displayed it as 2 08 17 not 1 08 17) I then took the chance to upgrade properly to the latest version again…I’m now waiting to see if the hang is cured.  If not I’ll just go back to the previous version again.  Thanks for your help…I’ll keep you posted!