Media library vanishes, then "No storage present" error?!?

Ever since I’ve had this device I’ve used two network shares (Video and Music) and setup a media library as demonstrated below -

All worked pefectly until this evening when both network shares disappeared and when I try and add them again all I get is a message on screen saying “No storage present”. 

I’ve checked the network settings in setup and they’re fine and I’ce changed nothing on the PC and double checked the two folders are still shared which they are.

Any clues as to what to try next?!?

Just to confirm.

In Network settings it passes the three tests and online services work fine.

From my PC (Windows 7 x64 Ultimate) I can see the WDTV live and access it using the device webpage.

My video and music folders are shared correctly (they worked for the past 3 months until an hour ago)

If I go to Files > Network shares > Windows > it just sits there spinning round and round until I cancel it.

If I go to Setup > System > Media Library > Add network share to media library > It then just says “No storage present”

Try restarting your Win 7 PC

moviebuff12 wrote:

Try restarting your Win 7 PC

Done that numerous times. 

What about re-sharing the media on the Win 7 PC. And leave for a while to make sure all sharing complete

MY PC consists of -

SSD (OS)

500GB HDD (Steam folder, various apps and programs)

1TB HDD (Video folder and Music folder)

It’s the video and music folder that were shared succesfully for months until this evening. I’ve also created a temporary folder on the 500GB drive and shared that but the WDTV SMP won’t see that either.

I’ve used the reset button on the bottom of the SMP to no avail. 

I just can’t understand it as the PC can see the WDTV fine and the WDTV can pull media from the PC via “Media Server” but it just doesn’t want to know anymore when it comes to network shares. Three months with no issues at all then I turn it on this evening and I have this problem. 

wdtv1.PNG

wdtv2.PNG

wdtv3.PNG

wdtv4.PNG

wdtv6.PNG

wdtv7.PNG

My HTC Desire can see and access the network shares on my PC but the WDTV SMP still refues too.

Is that and the fact my WDTV worked fine and suddenly stopped evidence to suggest the WDTV is faulty?

This is bizarre. It’s now working again.

I brought my laptop back from work and setup a temporary network share on that to see if the WDTV SMP would “see” the new share. However when I turned on the WDTV to check my old network shares re-appeared and the “No storage present” message no longer displays.

Weird.

To be honest I find the library mode very iffy . One day it shows and then the next day it says no storage present now for me too. I think the WD has a hard time with larger collections too bad you couldnt set it to not compile media library. Sometimes that kicks in all of a sudden and now the WD is unusable because compiling media library slows everything down. It was compiling last nite so I left it on over nite and this morning it was done but go to library and says nothing is there. ??? Hopefully things will improve library wise down the road.