Media Library Problems

I am wondering if anyone can help me. The media library has found movies and other item. How do you delete media from the library after watching. Have tried using the clear media section in setup. Even when I delete the watched items from on the MyCloud unit, the media library still shows them and will not pick up any new items that are placed in the shared directory.
Hope someone can help?

Forgot to say running Windows 10 Pro

Deleting items and updating the library for new content are explained in the manual.

Gregory, before I take time to write how I fixed/to fix this, do you still have the problem? I’m asking so that I can know it’s still unresolved before I write it all down. (I will keep a close watch on the thread for your reply).

Yes This issue of the library is still unresolved and I admit it is still very frustrating. Thanks in Advance.

1 Like

(I’ve attempted to make these instructions slightly clearer). An expert on ‘’ (link), although not specifically aimed at WDTV sharing, one of his ‘network sharing’ suggestions works for this problem, assuming your setup is either ‘network shares’ or ‘media server,’ and not a usb local disk share. It has solved this WDTV problem 3 times for me, before the update, since, and after a factory reset. If it doesn’t work for you, at worst you will have lost half an hour. The bit you need is halfway down in the link page where (expert) Richard says, “Can you do the following please.”

Put in that “0” value in the way Richard describes. (He lists many things in the link, don’t worry about those. (Watch out if you look at Richard’s other suggestions, don’t run chkdsk, you don’t need that and it takes hours.

Putting in this “0 value” in the way Richard describes is simple enough. What I had to do after his step is hard for me to be precise about. When you switch WDTV back on, you’ll find when you click the tile for your library content (videos) on the home screen it saying ‘no content available.’ It’s not serious, don’t worry!

See if your pc sharing settings need resetting. The thing that is most likely to have changed is folder permissions, very easy to correct. Right-click the folders you were sharing, select ‘properties’ and under the ‘security’ tab see that sharing permissions there are set to ‘all.’ Often while you’re there at the ‘sharing’ tab to do this, you’ll see sharing resetting itself of its own accord, making sharing available again, simply for you having navigated to it!

You may find, as you play about, that Windows will shut down sharing of its own volition, if so, it’s good because it means you’re home and dry and simply need to click to turn streaming back on, whereupon WDTV will have all files present, with none absent and no duplicates or redundant deleted files still displayed!

Where I can’t be as precise as I would like to be, is when I say that you will need to ‘play around’ with the regular sharing settings, both on WDTV and your pc – until Windows offers up this “Turn on streaming” option box of its own accord (meaning of course by implicaton that of its own accord, it has turned it off). Why Windows itself has to do this of its own accord, rather than you doing – I simply do not know!

Sometimes you see is Windows offering some movement on its own, namely (in ‘Netwok and Sharing) the message “please wait, sharing is taking place” Which is another route, and a good sign you’re close to solving everything.

Sorry I don’t have this all nailed down precisely as of yet, but as no one here has found any other solution that works when this problem becomes endemic and cannot be resolved with WDTV resets, or turning streaming off and back on, etc. I hope more people try this, and between us we can clarify the less precise second half and determine the fewest number of steps.

Sorry for not responding earlier to this question but have been away for a while.
I tried all the solutions mentioned but no joy in my case,
I have found in my case a solution which is working and I have no problems, This is in the settings for the media library. Just turn off the manage media library and I found everything is good. I can now change information on the WD cloud and it is reflected on the WDTV Box.
I thank every one for the kind assistance.
Gregory Tutin