Media Library Not Showing All My Video Files

Hi guys,

Last night I started my WDTV Live SMP and waited 1 minute for the unit to read my network shares and compile the library.

After that was finished I went to the video section , and to my surprise the total movies shows less then what it was the night before.

The media library should have 649 movies, and now it is only scanning 541.

When I went into the folders, one of the drives is only scanning 37 movies where it actually has 145 movies

I tried rescanning with no luck. I also deleted this from the media library and added it back, but still the same issue

When I checked the file section where I can browse all the my shared folders, it does show all my 145 movies for that specific shared folder

This is really frustrating, I thought having this unit would make things easier, but it’s a new issue every day

I just switch form a ATV2 running XBMC, and the file sharing was so much easier and consistent. The only reason why I switch to the WDTV was, because it plays all my HD movies without any stutter

I have to agree that the support is amazing on this forum, and that’s the reason I am still keeping this box.

Thank you guys for your hard work

Any suggestions to fix this issue are welcome???


It seems to be fixed after a factory resest

You could also select the option to clear the media library so it can rebuild it again. 

Thanks for the reply,

But I have noticed that Clearing the Media Library doesn’t remove all my files.

I had tried it twice, and it keep leaving one of the shared folders in the library


Try going into each of your shared drives/folders & find & delete all the .wd_tv folders, then do the clear & let it rebuild from scratch. Kind of a pain, but this should refind all of your files