MCH Duo Plex Media Server Problem to remote access

Hello dear community,

I have issues to remote access my Plex media server.

I really did not found any solution for the problem and maybe the Version of Plex Media Server on the MCH duo is a little bit old and “WE” have to ask WD for an Update or similar solution.

In other Forums they said that could be a certificate problem of the current version of PMS in MCH.

Is anyone else having trouble to remote access PMS on MCH???

PLEASE Answer…

Hi @murat1981,

The inability to connect to Plex remotely can be caused by:

  • Plex Remote Access is disabled
  • Router doesn’t support UPnP or NAT-PMP
  • UPnP or NAT-PMP on the router is disabled or not functioning
  • My Cloud Home is behind two network routers in a Double-NAT configuration

Please refer to this KBA link: 3rd Party App: How to Configure Remote Access for Plex on a My Cloud Home

Hello,

  1. Plex Remote Access is enabled
  2. Router is supporting UPnP
  3. Is enabled ( I also tried manually port forwarding)
  4. Only one Router

Anyway thx a lot for your reply.

I really think that the PMS Version on MCH is too old.

Maybe I will try another router to see, if it is depending on this.

It is not working, I tried almost everything.

Maybe someone else who have same issues with Fritzbox 6660 (7.28 Firmware) or generally with PMS?

Thanks in advance…