MBWE (Blue Light) not operational


#1

I turned off my unit because it was not been recognized by the network.  When I tried to turn it back on it would not start.  I saw that the network light was on in the back.  I pulled out the drives to see if they were not operational.  My PC saw the drives as available to format.  I want to recover the data.  Will getting another MBWE (blue light) and swapping the drives work?  Or is there another method.  If necessary I could build a linux box to attempt to recover the data.


#2

Windows cannot read the LINUX-formatted drives.  Unfortunately, you cannot swap the drives between enclosures.  That said, I recommend that you reinstall both back into the slots where they came from.  Do the lights turn on the front of your drive?  Please see the link below for more network troubleshooting steps:

WD My Book World or WD Sharespace drive is not detected by the Local Network or MioNet


#3

No it does not power on.  The ethernet port is lit though when the power is plugged in.


#4

What power supply are you using with the drive?  The drive needs at least 12V / 3A to turn on.  Have you connected the drive to a wall socket without a network connection to see if the lights turn back on?


#5

im having similar problem

i came home from errands and computers could not connect to device

at first inspection, the blue light was on and static…not blinking, just on

i tried restarting it by pressing blue button but no response

i then removed power, waited, powered up…now no blue light

network connection will get light and i can hear the hard drive spinning

but blue light not coming on and device still not connecting to computers


#6

What do you mean by what power supply am I using?


#7

What is the model number on the electrical adapter that you connect to the MyBook drive?  The drive should be able to turn on/off even without a connection to the network.


#8

DA-48M12 is the model number.  I hear the drives spin and the network light is on but nothing else is on./operational


#9

You have the correct electrical adapter but either the drive or the power supply failed.  You can try another power supply with the drive but if that doesn’t resolve the issue, I recommend contacting one of our data recovery partners from the link below:

http://support.wdc.com/recovery/index.asp?wdc_lang=en


#10

Whare can I can a new power supply?  What kind does it use?


#11

The drive uses the APD DA-48M12 electrical adapter.  WD’s Online Store does not sell them but you can call our telephone technical support to obtain one.

How to contact Western Digital for support (email or phone)