MBR failure on Elements 1042

My elements 1042 was disconnect incorrectly and now has an MBR failure which windows management disk storage can’t fix. Test disk will not run on this drive nor will Data Diagnostics for Windows (this fails with win mgs that will notify if solution found). Would love to recover this drive for the valuable photos it contains but if all else fails I need to know if this drive can be formed and if so how?

Win 10 is proving troublesome and I am seriously thinking about rolling back hopefully not as I quite like Win 10 but the last update was really annoying as it deleted a lot of installed apps. That’s another story and not applicable here.

Any and all help will be acknowledge with my grateful appreciation and returned help where I can be of assistance to people. Had this problem once before but that was using Win 7 and the problem was easily fixed.

Printers & Devices show the Element 1042
Trouble shooter can’t identify the problem
Disk Management Storage says " has a red circle with downturned white arrow Disk 2 Unknown and Not initialized and can’t fix.

MESSAGES FROM THE 2 PROGRAMS I have tried using to fix the MBR structure
[Window Title]
DLGDIAG for Windows

[Main Instruction]
DLGDIAG for Windows has stopped working

A problem caused the program to stop working correctly. Windows will close the program and notify you if a solution is available.

[Close program]

16 bit MS-DOS Subsystem

Command Prompt - testdisk
NTVDM has encountered a System Error
A device attached to the system is not functioning.

Choose ‘Close’ to terminate the application.

Close Ignore

Other than trying to diagnose your hard drive using WD Data Lifeguard Diagnostics in a different operating system, you could try browsing online for a 3rd party application able to write zeros to your hard drive.

If data recovery is a concern then it should be attempted before writing zeros to your unit. Otherwise all data could be permanently destroyed.

I’m also facing same problem and I’ve used WD Data Lifeguard Diagnostics and its showing as bad sectors and unable to complete the task.

I’ve tried to create a New MBR from Mini Partition Tool software but its taking me so much time… It’s displaying as MBR to be created to 2TB while my hard disk capacity is only 256GB… I ran the software for more than 20hrs and its not even completed 50% so I stopped it.

Any other solution?

not as yet. mine just maybe damaged but not sure yet. will post update as
soon as I know.
you could try if running win 10: 1. Windows Administrative tools; 2,
Computer Management to see if drive appears; 3. If drive appears see what
the error is by clicking on the drive and try to initialize it. There is
also a program called test disk that can be run from the command prompt as
administrator. If this program works it also might fix your problem. Give
them a try you have nothing to loose. Goodluck

Dear Shirley,

Hard disk is not showing in My PC… it’s showing in Disk Management but I’m unable to initiate it… I tried to rebuild MBR but its not accepting. It showing me it contains bad sectors…

Any other solution?

Try the following if you have bad sectors and maybe they will be fixed or
marked as bad thus the computer will skip them and use the good sectors

  1. Open File Explorer (Former known as Windows Explorer).
  2. Click on This PC.
  3. Right-click the Hard Disk you wish to run CHKDSK on.
  4. Click on Propertiesf your drive has bad sectors try windows check disk
  5. Click on Tools in the Properties window.
  6. Under Error-Checking, click on Check.
    CHKDSK Will now start to run on Windows 10.

I have no more ideas on how to fix your problem but I’m here if you need to