MBL Windows 8 and Java Issues


I have a 2tb MBL and installed it using my old laptop running vista. This worked fine and I linked in PS3, iphone and ipad, all of which work really well when accessing the drive.

Recently I purchased a new laptop running windows 8 and I am finding it impossible to link the new laptop to the drive.

Here is a summary of what I have tried and the issues I encounter

Discovery and setup of drive

I am able to run the CD that came with MBL, this discovers the drive then proceeds to offer me a mapping option - I accept and map the drive letter. Next the quick view software is installed successfully. I then get the “next steps” screen. If I select option 1 “Open your My Book Live” I get a Runtime Error, “This application has requested the Runtime to terminate in an unusual way”. When I click ok the MBL setup stops working. No drives are mapped and I can not view the shares.

User Interface

I can access the UI by typing the IP address / UI/# and this opens the dashboard showing Setting, Users, Shares etc. Here I have a fully functioning dashboard allowing me to create and edit passwords, shares and the like. I can see the summary bar at the botton but if I click view files I get this error message “The Java plugin necessary to open your shares was not detected on your computer. To download the Java plugin from the Oracle website, click Download”

I install the correct Java plugin (32 + 64 bit) restart but I still get the same error


Jave is installed and shows in the control panel. The applets are enabled and the addons are set in IE10. I have also set up exclusion rules in my AV software (Kaspersky 2013) to allow Java ro run unmonitored. However, diepite this I am continually asked to install Java when I use the UI

Drive Mapping

I am unable to mad a drive either manually or by usind WD link. WD link detects the drive, displays the IP address, allows me to access the UI to configure but will not let me map the drive.

Other WD Software

I have tried usind the MBL setup software downloaded from the WD site. This runs and appears to work but no drive is mapped and when I select the desktop shortcut created during the installation (IP address\Public) I am presented with the username/password windows security box which will not accept the share/password combination.

I have uninstalled Kaspersky 2013, rebooted without any AV but I still experiance the same errors.

Any suggestions? really frustrated, ive tried the WD support but they could not get it working either


Had the same problem on windows 8 64, found out  my browser firefox 18 had java disabled, enabled it and works now.