MBL isn't getting an IP address after reset

So I accidentally set the MBL Ip to a static IP and then realized that the **bleep** cable modem doesn’t support the address range I put it in.  I reset the MBL using the pin in the reset hole.  Now, it shows up on a network map as being attached, but it only has a MAC address.  It’s not getting an IP address.  The cable modem is set to use the 10.0.0.X ip range.  Should I try setting the router to use the 192.168.1.X range?  Also, the MBL is just flashing a green light, but it’s only been about an hour.  It’s got around 84GB on it, but that’s made up of a TON of files.  Mostly reference textures for 3d work.  I’m going to let it go for a day or so and see if it’s just busy indexing, but I wondered if the indexing would prohibit it from getting an IP?  The router is set to DHCP and I’m fairly certain I did the MBL reset correctly.   Just curious if there are any other tricks to get it on the network?

The reset button must be pressed for 4 second to restore the default configuration. If the router is not giving the MBL an IP you can connect it directly to the computer and setup the IP manually from there. To make things easier you can also use the WD Link tool. 

http://wdc.custhelp.com/app/answers/list/search/1/kw/wdlink

I reset the mbl.  Plugged the network cable from the PC directly into the mbl.  I had installed  the wd link tool previously.  So with this setup, I run the wd link tool and it can’t find the mbl.  The mbl just blinks the green light.

I can see it’s mac address in the network map but it has no ip address.  I turned off kaspersky completely to help troubleshoot in case it was blocking it and that didn’t help either.

By default the MBL workgroup is “WORKGROUP” be sure to use the same one on the PC.

1 Like

Made sure the pc is part of the “workgroup” workgroup.  I still can’t seem to get an IP address for it.  I’ve tried connecting it directly to the pc and using the wd link tool, but it can’t find the drive.  I’ve cleared the arp cache, flushed dns, tried static ip on the pc and used 2 different network scanners to look at all the devices on the network and it won’t show up.

The thing is, it obviously knows when it’s connected.  If I yank the network cable, the mbl gets a solid red light.  Right now I’ve got it connected the way it was before, which is directly to a gigabit hub which is linked to the cable router/modem.  I reset the cable modem and it also got a solid red light.  Then when the modem came back up, the mbl goes back to the steady flashing/blinking green light.  Also, if I unplug the mbl and look at the windows network map, the mbl doesn’t show up.  When I plug it back in, it shows up in the windows network map, but without an IP address.

Here’s a screen grab of the network map that shows the mbl, but with mac only.

nicmap1.jpg

In the cable modem/router, the mbl never shows up.  I also tried using a linksys wrt54g router connected to the pc and the mbl with the wrt54g set to dhcp and it doesn’t show up in the client table on that either.  The router succesfully hands out an ip to the pc, but not the mbl.  I also tried running the install wizard from the cd and it of course can’t find it either.  I tried manually setting an ip for the mac address using: “arp -s 192.168.1.100 00-90-a9-b6-13-e9” and then it shows up in the arp table with that ip address, but when I ping it it’s unreachable.  I also tried manually setting it in the cable modem router with a static IP linked to it’s mac address, but of course, without having access to the dashboard to set the mbl to have a static ip that matches, it doesn’t work.

loosing my mind a little.   I think for now I’m just going to leave it set for a while and see if the blinking green light goes steady green.  Like I said, it’s got a fair amount of data on it and maybe it needs to index it first?  It “feels” like it’s doing something constantly.  I can feel the hard drive spinning and doing things.

Any other suggestions to force an ip address on it?  Would a crossover cable directly connected to the pc have any impact?  It’s frustrating because I can see it on the network and I also discovered that it exists in the “devices and printers” list but it was apparently just an old version of it because it was greyed out.  I deleted it from that list.  Any help is greatly appreciated!  If I can’t get it fixed soon I’m going to have to go the data recovery route.  Any suggestions there?

1 Like

As a point of troubleshooting, you might try running a DHCP Server on your PC, disable the DHCP server on your router, and then look at the DHCP server logs on the PC when the MBL boots up.  It might give an indication of what’s not happening.

So right now I have it connected to a different pc that has never been connected to the mbl before.  I installed antamedia DHCP as a DHCP server on the PC.  It gives the PC an address but the MBL never registers and there is nothing in the log that indicates that the MBL is even trying to get an IP from it.  The MBL shows up in the windows network map right next to the PC but again with only it’s MAC address and no IP.  I can’t reach it via browser at http://mybooklive/UI/.  It’s like it’s on a different subnet but I’ve tried the usual subnets with no success.  The interesting thing is, when I look at the status of the adapter, there is data being sent and received between the PC and the MBL!  Everything shows the link is up.  The NIC has some nice troubleshooting features where it tests the cable and connections.  All the troubleshooting in the NIC shows the connection is good.  When the NIC runs a diagnostic test, it goes offline for a minute to test connectivity.  When it goes offline, the MBL gets a solid red light.  When the NIC comes back online, the MBL goes back to the flashing green light on the front.

I for the life of me don’t understand why WD didn’t put some sort of utility port on this drive.  I’m stuck with a brick and no way to access the data.  Obviously something is wrong with the os on the drive and there is no way around it.  I even tried plugging it into a linux laptop directly and couldn’t see it.  I tried http://mybooklive.local on the linux machine to try to access it and nothing.  I don’t think I’ll ever buy another NAS that doesn’t have some secondary method of connecting to it.  It’s a stupid design.  I thought it was odd when I bought it, and I’ve never been comfortable with this drive for this reason.  The worst has unfortunately happened.

You sound pretty network-savvy… You might try running wireshark on the pc to see if you can discover what the MBL is doing on the network.

1 Like

I forgot about wireshark!  It’s been a while since I’ve had to troubleshoot something this bad so a lot of the tools have slipped my mind.

In wireshark, I’m able to see when i pull the network cable from the back of the MBL.  The logging freezes in wireshark.  As soon as I plug it back in, BAM, crazy activity.  Now I need to sift through what’s happening.  I think from an initial scan of the packets that the MBL is on a different subnet.  I’m also seeing a lot of bad tcp flags.

This might work.  If I can sort out what the MBL is looking for and not finding, maybe I can trick it with the antamedia dhcp server.  At least I know there is communication happening between the MBL and the nic.  I’m seeing UDP and TCP and some ws discovery stuff in here.  Would it help if I posted some wireshark captures?

Little more info.  I think I found the MBL.  I found a packet that is a request for URI from the drive.  It’s identified as “device:wdnas” so I’m assuming that’s the mbl.  It’s requesting the URI http://239.255.255.250:1900

I don’t know from this what the subnet is though.  It looks like the drive has the ip 230.255.255.250 but I can’t ping that so I’m assuming it’s on the wrong subnet?

239.255.255.250 is a registered multicast address for Simple Service Discovery Protocol (SSDP). What is the SOURCE address of these packets?

Just googled that. LOL.  The source is the PC’s IP which is what’s confusing…

Ok,  next thing I found is an ICMPv6 protocol packet.  It’s a router solicitation from the MBL.  It has the MBL MAC address in it as well as it’s identified as the source “WesternD_b6:13:e9”.

Can I use the ipv6 address to “talk” to the mbl?

If the source IP is the PCs IP, and you’re sure the source MAC is the WD, the it looks like all you need to do is temporarily readdress your PC so it is not conflicting.

Out of sheer curiosity.  Make sure IPv6 is disabled on your PC and if your router is IPv6 capable, disable that too so your LAN is IPv4 and see what happens.

I discovered why the source is the IP of the PC.  apparently, the WD Smartware software makes FREQUENT calls looking for wdnas devices.  It’s not the NAS communicating, it’s the WD Smartware.  I learned this by installing wireshark on another machine that isn’t connected to the MBL.  What’s alarming (sort of) is that the smartware software constantly sends out M-search broadcasts looking for a drive.  Creating network traffic constantly.

All of this isn’t good for me.  The only good thing I’ve figured out is that when I create the network map in the network sharing center, I do see a ton of traffic coming from the MBL, but again, it’s only it’s MAC address.  I’ve got to give up on this for tonight.

So here’s a screenshot from wireshark when the MBL comes online.  The first entry from the MBL shows the source as “::” and destination “ff02::16” on the ICMPv6 protocol as a “Multicast Listener Report Message v2”

That packet in the detail section identifies the source as “WesternD_b6:13:e9 (00:90:a9:b6:13:e9)” which is the same mac address that shows up in the windows network map.  Does any of this make sense?  To be honest, I’m in way over my pay grade on this.

connection.jpg

I think I’m about at the point where I’m going to pull the HDD from the MBL and try putting it in a linux box.  I found some good info on getting data off of it.  Any final suggestions before I break into the case?

My most recent effort was to install DD-WRT firmware on a Linksys WRT54G which has the possibility of forcing an IP on the MAC address of the MBL.  The firmware is nice but I still can’t see the mbl and the forced ip address doesn’t work.  There’s also a WOL feature in the firmware.  I forced it to try to WOL the MBL with it’s mac address.  With wireshark I can see the router broadcasting to the MBL’s mac address, but it’s not responsive.  

I think it’s essentially bricked.  I don’t know why either.  Initially, all I did was a reset (hold pin in reset slot for 4 seconds).  Everything I’ve read says it should reset to the default settings.  That’s obviously not what happened though.  Really not happy about this.

Copy down the MAC address you’re seeing from the MBL.

Verify that it’s a WESTERN DIGITAL address.  Probably begins with 00:90:a9.

Open up WIRESHARK.

Star the capture.

Let it go for a few minutes, then stop the capture.

Set the DISPLAY FILTER to:

eth.src== 01:01:01:01:01:01

and change those 01:s to whatever the full mac of the WD is.

Such as 

eth.src== 00:90:a9:01:02:03

… and then click the APPLY button.

That’s going to give you more pertinent info.

1 Like

I GOT IT!!!

I ended up pulling the HD out of the case.  I installed a fresh WUBI on one of my machines, plugged the HD into the sata port on the machine and booted into ubuntu.  Ran this script:  http://mybookworld.wikidot.com/forum/t-368098/debricking-script-that-can-keep-data which completed successfully.  Shut down the pc, pulled the HD then put the controller board back on the HD and plugged it into the network.  Started up fine.  I ran WD link and it showed up right away.  Best part is, all my data is intact and it didn’t cost me a cent!!!

Many thanks for all the help here.  In the end, i’m afraid it’s a bit more trouble than the average consumer is going to deal with.  I still think there should be a secondary utility port on these things.  I’m off to research a better redundant storage system.