MBL Duo, Macbookpro wired connection super slow

I have a MBL Duo connected to an Airport Extreme and on to my Macbook Pro (mid2010)

I also have a 4 year old NetGear Ready NAS on the same router.

I am getting very slow speeds on the MBL:

write: .9 MB/s

read: 2.6 MB/s

On the ReadyNAS I get:

write: 7.2 MB/s

read: 2.8 MB/s

On a local USB drive I get:

write: 26.9 MB/s

read: 27.0 MB/s

This is all gigabit so these times seem incredibally slow, especily since the ReadyNAS is very old.

Can someone let me know if they have any ideas of what might be going on? Both are set to DHCP.

I got these numbers using the AJA System Test free app.


I’d probably be looking for bad cables.

It’s not cables.

I even tried using the ReadyNAS cable on the MBL duo and get the same results.

Could the device be defective?

You may have an issue we’ll be releasing a firmware update for shortly. If so, you’ll want to contact a Level 2 tech and let them know; they’ll be able to help get it resolved for you. To help them determine if it is the issue, create a Support Ticket from the My Book Live Duo’s dashboard (under Support) and mention in the ticket that your device is very slow. Quoting the speeds mentioned above will help give them an idea of its speed.

Hi Fxguy

With a CAT6 cabled link to my router I am getting figures not that dissimilar from your USB-connected drive. I am seeing 23 - 24MBps.

My wireless figures are close to yours with my Airport Extreme in a MacBook Pro but when I substituted an external Alfa 2000mW wireless adapter for my AE the performance figures increased 4-fold, typically 8 - 10MBps.

I have several USB HDDs I can connect to my MBP but the fastest, ironically made by WD, will backup at 3GBpm (equiv. 50MBps.

Are you using Time Manager?

Still getting the same read/write times and have gone back and forth with tech support multiple times. None of them talked to me about a potential issue a level 2 tech could help with a possible firmware update.

All media sharing is off.

the green light has been blinking since purchase.

If I run a diagnostic, short or long it stops at 90% and never completes.

I had time machine working for a week or so, only by dong a backup on another drive then copying it over and re-pointing it, but eventually got the error it was corrupt and had to be re-done.

I am doing a full factory restore once I finish copying off 1.5tb of data which took a week to copy in the first place.

If this doesn’t do anything I assume the next step is to try and return the drive and buy something else.

I don’t know if this is still applicable, but I remember there being some configuration changes you can do on the Mac to improve performance. See the blog entry (pretty old -so I don’t know if they have resolved this in newer OSX versions).



I did a factory restore and got read and write times I expected.

I then did the firmware update and the times got even better.

I then went to convert to the mirrored configuration and it failed during the conversion and said to contact customer service.

Blue light is now on all the time and nothing can see the drive.

I put in an RMA for advanced repacement and am hoping the new one will be more functional.

This was whole ordeal has been a lot of effort for what is supposed to be a plug and play consumer product.

After 2 weeks of just copying data onto it before I realized there was a speed problem I am very unhappy.

Tech support has really not been helpfull with the best response being restore your drive to factory settings.

I would think my system has been defective from the day I got it a little over a month ago, but with the problems I was having the second response from tech should have been to send it back and get a new one.

I will let you know how the new one acts.

(for some reason I now have two forum accounts here with the same user name?)

i am having similary issues - I have an Intel iMac running OS X 10.7.4, and have the MBL duo connected directly to my computer.  I initially used it only for time machine and had no issues.  I later tried to transfer my itunes and iphoto libraries to it, and the speeds went way down.  I had the same experience with running the tests as well - they would get to 90% and quit (I let one run for a couple days).  Here’s the difference - I have gotten replacement drives.  I got a second hard drive - and had similar issues (including potential loss of the majority of my iTunes library!).  I contacted tech support and they have sent me a third hard drive, which is right now backing up on time machine.  I started Time Machine last night, after setting up RAID, and it said it would be about 17 hours to transfer 175 GB.  It’s now about 13 hours later, and 52 GB has been transferred, and the time remaining is “About a day.”  I don’t have a way to tell the exact speed, but it is definitely slowing over time.  It is apparent there is some sort of compatibility/connectivity issue with the macs that gets worse the more data you put on the drive.  I also have never heard of Level 2 tech or firmware updates, but apparently that doesn’t work.  Anyone else have any more suggestions? 

UPDATE:  I stopped my Time Machine backup and loaded the firmware update - then time machine worked like a champ and backed up what was previously supposed to take “about a day” in a couple hours.  I thought maybe my luck was changing, so I tried to transfer my iPhoto library too…the time estimate is about 5 days for 36 GB!  HELP PLEASE!

Hi Fxguy

I did boost my backup performance to 30MBps by reverting to a cabled connection to my router. By using a high power wi-fi adapter (Alfa 2000mW) I achieved 12MBps. Using Airport I never achieved better than 3MBps. I guess these results indicate how to achieve the best performance.

I recently performed a firmware upgrade and whilst performing the ‘short’ diagnostic I found it stuck at 90%. I could not get it to complete no matter how many times I tried. It would complete with the previous firmware. A firmware upgrade too far?

I still haven’t got Time Machine backups to work but copying files between my MBP and NAS is both fast and accurate. 

Hi nickvilardi

I have had my MBLD for about 2 months and I’m still waiting to achieve my first Time Machine backup despite a recent firmware upgrade which seems to have made things worse as far as performing diagnostic tests are concerned. The short diagnostic sticks at 90% and never completes.

Copying files between my MBP and NAS works well and fast provided I use a cable between my MBP and router. For best wireless performance I have to abandon Airport for a hi-power Alfa wi-fi adapter.

I have been trying to backup over 400GB and it takes close to 1 week but when it gets to 400GB the backing up keeps going. I let it get to 1.1TB (1100GB) before I abandoned the backup and started again. Time Manager backing up still doesn’t work but copying files works well.

Hi Tony,

If MBL Duo runs on Debian (true?) the last posting in the Julipedia-thread is promising:

“However, I would like to post an addendum that I was able to fix this problem without modifying OS X configurations by removing SO_SND and SO_RCVD options from my samba server running on Debian.”

Please explain us how to, or - even better - include this fix in the next Firmware-update!




Placed Advanced RMA last Friday, status still only showed “submitted” today.

Called in to check on delivery, was told it was out of stock and inventory only updates on Sundays.

Was told if they have any Sunday it will ship out Monday.

Over a week to “possibly” have an advanced RMA shipped out does not give me any confidence in this product or its support.


I received the new unit, (thanks WD for expediting it!)

Ran great at first, speeds were what I expected.

Now as I have my data back on the drive it is extremely slow again.

It takes 5-10 seconds to oen the dashboard or switch pages on it.

Green light always flashes. Even if that is the only device on the network.

DLNA and iTunes are off.

I can’t even get it to complete the short test in utilities. It gets to 90% and then displays this message, or displays it immediately and jumps to 90% but never finishes.

Error 31314


Error 30000 unknown error. Please ensure you are not facing network connectivity issues and try again.


Any ideas as to what is doing this?

I have the drive mirrored and have 1.9TB used right now.

There are lots of image sequences but that shouldn’t matter.

I also excluded the shares from spotlight but I don’t think spotlight looks at network drives anyway.

Also after time machine has been running great for a week or so, I got the message that an error had been found and i had to make a new backup.

For 400gb it took 3 days on a gigabit wired connection.

Hi fxguy

What happens if you drag-and-drop files to your MBL Duo? Is it fast and error free?

Dragging-and-dropping works fine with me, it is Time Manager backups that I’m having trouble with. I have 410GB to backup but it will take a week or more to complete, if it completes without errors.

WD Support has offered me dedicated assistance with my TM problem which I have accepted.

Full Time Machine backups like it just made me do took about 4 weeks for about the same ammount of data. The first one when I got the replacement unit a couple of weeks ago only took about a day.

I was able to try running the full diagnostic test but 2 days later it is stuck at 90% and has been for at least a day.

I can drag and drop files but it is slow.

Any ideas?

Hi Fxguy

I am no closer to making that initial TM backup despite the recent firmware update. Drag-copying is very fast so I am confident that there is no problem with the connection. I cannot fault WD Quick View and when I run diagnostics on the NAS it reports ‘Good’. But still TM does not work correctly. Like you TM operation seems to slow down with time.

I have therefore decided to look at the problem from a different perspective. I have asked myself the question, ‘what factors can affect TM operation and cause it to slow down or even fail?’ I am making the assumption that there is no problem with the NAS or its associated software. The list of factors isn’t that long but there are some obvious candidates that come at the top of my list.

I use Intego Internet Security Suite (VirusBarrier X6) which I know defaults to scanning CDs, DVDs, HDDs, other storage devices INCLUDING network storage devices. I am now corresponding with Intego to try and determine when the scanning takes place. Obviously VBX6 will scan (by default) the NAS when it is first detected unless the NAS has been declared as ‘Trusted’. But is this the same as saying that VBX6 will never scan the NAS? Is the ‘slowing down’ phenomina caused by VBX6 checking the data as the transfer progresses? With a little imagination I could envisage VBX6 putting the brakes on a transfer, especially if the volume of data is large, 408GB in my case.

I have therefore taken the first step and declared my NAS to be a Trusted device (it wasn’t previously) and Net Monitor is indicating to me that the ‘slowing down’ issue has been significantly reduced. However, the backing up performance is still not wonderful. There maybe other factors influencing the backup that I have yet to discover. 


Have a look at this: