MBL - Disconnect issue on iinet Bob (original)

Hi, I have managed to set up the MBL, it has a static IP and I have assigned/reserved that IP through the router set up…but it will only stay live for a few hours at most and then it disconnects and I can no longer access it. The only way for it to be accessed again is by resetting my router.

Using My Book Live 3TB

with Belkin ‘BOB’ router via iinet (this is not the current Bob2, but the original one)

Greatful for any offers of advice…but be gentle I am only new to this stuff :wink:

PS I have updated the firmware after install. Have only had the unit a few days.

Hello littleramblings,

Have you tried resetting the drive? Also if possible test the unit with a different router to make sure that is not a router/configuration issue.

Thanks Help4All

I haven’t reset the device as yet, will this result in data loss? I had previously purchased a My Cloud and had the same issues even after resetting, I am worried it may be my router, however I have seen others with the same issue. I don’t have a spare, so was hoping to not have to go and buy one…looks like I might have to anyway.

“it has a static IP and I have assigned/reserved that IP through the router set up”

Hmm, I wouldn’t do that. I would recommend you use one or the other such as:

  • Static IP not part of the DHCP pool


  • Set to DHCP and reserve IP on router/DHCP server 

Is there a reason why you wouldn’t recomment that? I have changed it now to the second option.

Still having the same issues…it will not stay connected for more than a few hours at a time…has anyone got any other thoughts on what the problem may be??

It is strange that it works fine everytime I turn my router on and off…and then after a few hours it is no longer connected (the LED light stays green the whole time, it also continues to make noises as if it is connected).

Hi - I don’t know if this will help, but for ages I have been having problems with accessing my MBL on the network.

What I did to resolve this was instead of mapping to \MYBOOKLIVE\PUBLIC I mapped it to its static IP address \XXX.XXX.XXX.XXX\Public and since then I’ve not had any problem with it mounting on restart or intermittently dropping off network.

Hope it helps.

Thanks for that AmberViking…will give that a shot. Fingers crossed!

Gave that a shot AmberViking…unfortunately it didn’t help, it still disconnected itself about and hour later.

I have contacted support again, this time their answer was to do a full factory restore…at this stage I haven’t actually got much on the drive, so was happy to give this a shot. It seemed to be progressing fine, then said it had successefully restored and was going to reboot. It then lost network connection and hasn’t worked again since. I have restarted the router, which is how I normally get it to connect again, however this time nothing is happening. The green light is on, but it can not be found.

Will contact support again, but I am starting to think this one will end up back at the shop just like the My Cloud did :frowning: