MBL can not see on router or access via computer

I have  2 year old MBL. Never had issues with it and then the other day it was working then all the sudden i couldnt access my files and i was trying to reset it and it got dropped onto carpet about 3 feet or so.

I dont know what is wrong but i was starting to have issues and not able to access my files via NFS or windows SMB.Only sometimes though.  No trouble accessing via my computer though.

Now i cant do anything with it since i did a reset. I tried accessing it via the ip address i know it is on. I tried resetting it and unplugging it and i can hear the drive spin in there and i can see the lights on the back blink. The front LED quit working not long after i got the drive.

I have almost 1Tb of stuff stored and i dont want to lose it. Is there a way to access the stuff or a way to get the drive to respond and show up on my computer?

Thank you 

As a last resort you might try Steve Gibsons “Spinrite” a try. I’ve heard nothing but positive reviews and success recovering files from damaged hard drives. I actually tried to damaged a hard drive to see how many slams into the carpet it would take to make it fail while running, believe it or not 7 tries before it started to make any noise a (scraping) sound, before it failed to recognize the file system. It was a 1 terabyte drive from Samsung. I’ve never used his product it will set you back almost a c note and can be found at grc.com.

This doesnt answer my question.

the drive is not sounding any different then normal. i know what a drive sounds like when it goes bad.

i just dont understand how it was working then not, even before the drop. Spinrite seems to be overkill. The other issue i have is how do i get data off of a drive that i cant see? Remember i can not see this drive connected to my router, i cant log in via the ip address and i cant access it via my computer.

That spinrite is as I said a LAST resort if your files are important. Take the drive out of its case and mount it in your mac or pc and see if its recognized, if so retrieve the files off it which you would do anyway with a date recovery software then use it as a backup drive. Dono if replacement parts are available from WD. Read linux files from windows using the link below. Its free.


how would i mount it? Would i need a case? Since the only hookup is a ethernet

When you hit the reset button the following happens,

  1. Removes owner password.

  2. Set default password.

  3. Changes network configuration to DHCP.

So, incase if you had a static IP for your MBL, it will no longer apply since its now changed to DHCP. So, try to get the IP address from ‘WD Quick View’ if you are on windows or mac. 

i had dhcp address. I dont know what to do with the WD quick view. It seems to do nothing more then put a system pref that says do i want it to open or not when i log in. 
Unless its this little icon in the menu bar that says superdrive but it is greyed out. 
IM on a mac. 

Also i had no password set on it. IM not sure what to do now. 

Had you enabled ssh before?

I dont believe i did. But even if so i dont know the IP address to SSh into. 

I did some more reading on the WD quick look and all it does for me is show something called superdrive and its greyed out. 

You can get the IP adress from the “wd quick view”. But, for that your computer has to recognise the drive. Going by what you said, I don’t think your computer is recognising your drive. Incase if you have a router, please check the list of devices connected to it, and get the ip address from there.

That is the issue it doesnt show on the router, computer and i cant see it with my apple tv either which i normally use it for.

It doesnt show up anywhere yet i can hear the drive spinning in there when you start up and everything. It wont be now because it was set to go to sleep if i dont use it for awhile.

OK now for some reason when i restart my computer or turn it on i get an error message saying

THERE WAS a problem connecting to server mybooklive

The server may not exist or it is unavailable at this time check out the name or ip address check your network connection and then try again.

any idea what i can do?

I have 100% the same problem. No front led lights, ethernet connector green, power supply ok, same 2 years old same no clue. Suddenly stopped never dropped.

Its frustrating to say the least. I have the drive almost full and dont remember all i have on there so finding all of that again is going to be hard. That and i dont want to spend money on another drive when this one should work ok. 

Just weird that all the sudden it comes up and the computer sees it enough to know its there just cant get an Ip for it.

I’m in eaxactly the same situation - the only difference is that I can see the drive on my router and can ping it, but can’t access it from my Mac - if anyone has any suggestions, I’d really appreciate it - even if I could just ge tmy data off and start again…

Thanks in advance!

welp, I’m now in the same boat.  MBL been working fine for two years, I am 3 firmwares back, the last real stable of the 2.0x firmwares.

Nothing about setup changed.  I just noticed that quickvew didn’t show all the options, an indicator that it lost connectivity with the MBL.

  • I revoked the reserved DHCP on my router and rebooted it.

  • I held in the reset button for 5 seconds and then power cycled the MBL.

 The device is not seen in the router now at all.  LAN port shows solid green and blinking green

I tried to do a direct connect to the laptop, laptop set to dhcp, private network, but network map shows nothing.

Put the MBL back on the router, rebooted everything again…still not even showing up in the router.

I guess the options are to try a different cat6 cable and to try moving the power directly to the wall.  that will require moving the whole entertainment center.  but it’s been fine for 2 years, nothing in the setup has changed.

did you guys every get yours up and running again?  I don’t see the point of debricking the drive if it’s just going to randomly die;  it wasn’t a firmware update or anything that bricked it.