MBL 3TB invalid password after reset

Hi all,

Please help me with this problem. I set up wrong IP adress and made reset via button… All is OK, IP adress is DHCP, MBL is ok on network, but dashboard is inaccessible for me “invalid password”

There is not password after default reset, but i tested “admin” “Admin” “1234” “123456” and old password…nothing.

SSH is not enable unfortunately.

Thank you


I would try holding the reset button again for 4-6 seconds. The drive should reboot during this process (look for led changing colors) and clear the dashboard password and reset to DHCP like you said.
If it still doesn’t work, without SSH access, I’m afraid you may have to RMA the drive

Solved…rebuild partitions



I was gonna suggest my guide but wasn’t sure you would want to tear your drive apart. Glad you are all fixed up…

Yes, your guide :-), good job and thank you.

It was last my choice…button reset did not help (many times).

All is OK now.


You may want to take a look at this guide as well, it could save you from tearing apart the drive should you have similar issues again


Yes, i know this GUIDE, but…


  1. Open the dashboard… (I didnt access to the dahboard)


  1. Enable SSH access…  (I didnt access to the dahboard with ssh enabled)


  1. Enable SSH access…  (I didnt access to the dahboard with ssh enabled)

Last choice was take out hdd…

Now is ssh enabled :slight_smile:

Thank you


No what I’m trying to say is installing it NOW could save you that hassle in the future :wink: