MBL 1TB Network link down


Sorry to drop in on your thread.

I am having the sam problems running vesion 1.02.03.

I have tried using DHCP and static IP adresses, but to no avail.

I am running a Linksys WAG54G wireless router.

Come on WD Support - what is going on here??

Another observation… when the drive goes into standby and the LED goes blue, it’s not possible to wake up my MBL. This isn’t the only time I lose the network, but I can guarantee it will not wake once the LED is blue. In fact, my switch shows the MAC on the network but no IP or name listed against it. It’s like it loses it’s network config.

This is going to sound odd, if not borderline insance… Overnight and for all of the day so far, my MBL has stayed online and been able to be detected from a Twonky device, via Windows SMB and via WD2Go on Android. This is the first time since upgrading to 02.02.02. Overnight, it went into standby (blue light) but successfully was woken by a Twonky client (albeit after a two or three minute wait).

What did I do? Well, this is the instance bit. Turned it over!!! Now, I’m not saying it’s fixed yet at all, but yesterday I was sorting out the position of my Sky HD box, WDTV Live and MBL and all I did was turn it over. I assume the hard drive is now the correct way up so the head and spindles are not fighting gravity. As you look at the WD from the front (it’s horizontal BTW), the logo and vertical stand feet are on the left. From the back, the retaining clip for the LAN cable is top side.

Since doing this, it’s stayed online.

Cooincidence or something to do with the drive position?

Try it and feedback here. I’m investigating every option at the moment!


I don’t think it’s ever supposed to be horizontal…see that other guy whose drive got up to 90 degrees real quick.  It should be vertical (like a book on a shelf), with the colored LED indicatot at the bottom.

There are two things: 

My NAS won’t enter sleepmode.

Allthough it won’t enter sleepmode I get the message: “Network link down” Get that everytime I start the software. 

I updated to latest firmware and gave it a static IP-adress. Don’t know what to do next. 

Maurize wrote:


Allthough it won’t enter sleepmode I get the message: “Network link down” Get that everytime I start the software. 

It will continue to issue that error if you don’t ACKNOWLEDGE it.

another user here with this error. i am on DHCP as i don’t think switching to static IP will correct the error.

running the latest firmware, don’t see any problems or issues while interacting with the drive, however it would be nice if WD could take care of this in the subsequent release of firmware.

as for features, i would have liked to see some enhanced or advanced settings that can be changed by the user. a WD support guy mentioned in this thread that MTU can be accessed, but there is no user adjustable setting for MTU within the NAS.

Thanx, it worked. 

NAS still won’t go to sleepmode. 

In the systemmenu I enabled hard disc sleep after 10 minutes. Could software be the cause? I mean the NAS goes to sleep after being idle for 10 minutes - when there is activity it is not idle so it won’t go to sleep. I use True Image for backup - could that be the cause? 

Resetting to factory defaults is an option - but it’s the last option for me. I have a lot of movies on the NAS. 

Hi! I’m having the exact same problem with my My Book Live… The UI goes crazy and reports tons of the same error!!

The UI have also been pretty slow, but especially after having copied all my files to the HD, it’ve been REALLY REALLY slow… It’s so annoying, because you can’t do whatever you want unless it takes a loooooot of time!

And to make it better, I just gave the admin-user a password, so every time the link goes down (in a special way?) I have to enter the pass and start over again… It’s so fustrating!

And I’m not connected through a switch/router, it’s connected directly to my computer via the network cable.

Really hope this will get fixed soon! I have firmware 02.01.06-026, but not sure if I should upgrade to 02.02.02 - seems like it doesn’t help? Just makes it worse?