MBL 1TB Network link down

Hi, I’ve using MBL 1TB for a month and experienced problems with the product. I wanted to know if anyone has received a warning message on the control panel saying: “The network link is down or has become intermittent. Please check your network connection.”

I don’t find any problems on the network. My router is a linksys wrt54g but doesn’t seem to be the problem. When trying to connect from different computers sometimes the device link doesn’t show off and suddenly then starts to work again.

Any help would be really appreciated.


YES.   Just today as a matter of fact, for the first time. 

I had just copied over 40 gigabytes of BD files to it, and that’s when it started happening.

I have my MBL set to send E-Mail alerts, and my Blackberry started going NUTS.

I had to reboot the MBL to get it to shut up.

But in my case, it actually WAS dropping off the network.  I started PINGing it from my desktop, it’d stop responding for 5 to 10 seconds, and then resume, and the e-mails would come.

Thanks for your answer, I’ve pinged the device and It’s response time it’s about 3ms average. This values are ok, aren’t they? I don’t know then why it keep me throwing this warning message.

3ms seems a little long to me, but not out of the realm of possibility… 

Just try rebooting the box and see if the problem goes away.

1 Like

I’m also getting this problem, but it has only started happening since I have upgraded to the new firmware. The mbl is connected to a belkin wireless g router.

Any ideas as Im pretty stuck.

restarting has seemed to fixed it

I’m seeing the same problem.  Restarting and powering down have not helped.  the MBL device is dropping its network connection so often that neither Acronis or Win 7 backup can successfully backup the system.  These two programs ARE able to complete successfully on another NAS device on the same network (sitting next to the MLB).  No other system or device on the network is experiencing this problem.

I can’t say if this problem was occurring before the latest update, when I installed the MBL a couple of weeks ago it prompted me to upgrade the firmware.  The upgrade was done before any backup was attempted.

Any help with this issue would be greatly appreciated.


I have been having the same problem since installing the MBL. It updated firmware on initial set up and now gives me the message: The network link is down or has become intermittent. Please check your network connection.

I have checked the ISP, Modem and Netgear Wireless Router WGT624 V2. All seem to be to the latest versions and working correctly until I installed the MBL. Unplugging the modem and router fix the problem for a short time. This is a real pain in the neck to unplug modem and router everytime. 

Any suggestions? 

I wanted to write back and state that I have been having this error for about 6 months but was finally able to correct it. I had to reserve a IP address on my router for the MyBook, then I went into the network settings of the MyBook and created a static connection for it, from the DHCP connection this now has taken my MyBook to a better communication level and improved network performace.

Now If I could just find out why the light on the front of it works when it wants to…

I’m having the same problem.  could you be more specific about how to reserve an IP address on your router for the MyBook.  and how do you create a static connection for it from the DHCP connection.  I am decently proficient with computers but I am not familiar with all of the details of networking.  I have a Linksys Wireless-N Giga Router (WRT310N).

Thanks for any help.

I just purchased an MBL 3Tb. I also have a WD TV Live Hub. The drive installed with no problems. At first I could see it on the network and map a drive letter on my comnputer. Then I upgraded the firmware and I am now also getting this error message. The drive is no longer visible on the network. Have sent  WD support a message. Waiting for a reply.

Just to follow up from my previous post. I have tried everything, from rebooting to creating a static IP address. Still getting the same error.

I bought my MBL on version 2 firmware, but not version 2.02.02. I never noticed any problems when I first set it up, but since upgrading to 2.02.02 (at least I think since then) the network has become so unreliable. I even had complete loss on the network and the LED was switching between green and yellow. Had to hard reboot to get it back online.

I can connect to Twonky one minute and list a load of tracks, then suddenly get disconnected and not see the MBL on the network for 5 or 10 mins. There’s no pattern to it, but the network is definitely dropping.

I’m running with a static IP address, hooked into a Netgear 1Gbps router which is serviing my WDTV Live and Sky HD box just fine.

Openend a ticket with WD but very unhappy with this one. If it’s firmware, and there’s more people like us with the issue, you’d expect some kind of statement in the troubleshooting section, or a new firmware with the bug fixed.


Anyone know where to get the previous firmware versions so I can force a downgrade? Not found much on a search of the WD Support site

Finally found where to download previous firmware version. I’m going to rollback to each tonight and see if it’s a problem with 02.02.02. My only fear is that it’s a problem with v2 and I’m not sure if rolling back to v1 is supported.

Anyway, if you want to try a rollback to the previous or earlier firmware, here’s the links and the how to…



From the main dashboard screen, click Settings.Under the System tab, click the Updates heading to expand the section.Click the Update from File button.Browse to the location where you saved the firmware file and select it.Update Firmware pop up window will appear, then click the Ok button to proceed with the firmware update. Once the process is complete, the device will reboot. This process will take a few minutes.

If you have not upgraded, would like to see your logs to see if we can spot anything. We changed the MTU settings on the My Book Live to get the MTU size from your DHCP router. It is possible that that could be part of the issue. Can you go into settings on the router and see if you can find anything related to MTU? Is the Sky HDD box also a DLS Modem?

Hi, glad I found this thread as I thought I was just an ■■■■■ (arguable) or doing something wrong.  Same issues, and the drive does seem to causes issues with my Vista laptop. 

How did the firmware rollback go?

Variable in my scenario - in attempting to resolve this issue, I updated the firmware for my router, and lost all settings.  Do I need to set any application forwarding / port forwarding on the router?  

Thanks for your help.

As a side note, I have found that locally FTPing into the drive does provide a more stable connection.

Hi Tony,

Thanks for the quick response.

A couple of things… The MBL is configured to use a static IP address so I’m not sure how it will get MTU from the DHCP server in those cases. Perhaps that’s an oversight in the firmware, that there’s no default MTU for statically assigned IPs?

The SKY HDD box is not a modem.

My setup is as follows:

Netgear  DG834GT ADSL router courtesy of Sky (4x 100Mbps switch ports)

Netgear WNR3500L Wireless N router (4x 1Gbps switch ports)

The wireless is disabled on the ADSL router. It’s just running the ADSL modem and acting as the gateway for the network.

The WNR3500L runs the wireless so I can get Wireless N, and my MBL and WDTV Live are both connected to the 1Gbps switch on the WNR3500L.

I’m not using the WNR3500L as a router. It’s simply uplinked to the other Netgear via one of the switch ports and acting as a wireless access point and four port 1Gbps switch (I bought it for the Wireless N and Gigabit to connect the MBL).

So the whole network runs on a 192.168.0.x/24 network. The ADSL router is and acts as the DHCP server, DNS server and gateway. The MBL is on and the WDTV Live is on My WNR3500L acting as the 1Gbps switch and Wireless N access point is on

I have two Sky HD boxes connected into my free ports and they are picking up IP addresses from the DHCP server. My DHCP scope does not extend anywhere near the addresses used for the MBL or WDTV Live.

So, in short the MBL is connected to a 1Gbps switch using a static IP address :slight_smile:

For those others who are interested, the rollback never worked. It appears that using the GUI or SSH sessions that you are restricted from rolling back to a previous version. Incredibly frustrating and suc ha major oversight by WD as they’re assuming all new firmware releases don;t have any bugs which could require a rollback. Only platform in my 12 year IT career that I have seen which prevents a firmware/software rollback.

Any more tips?


Tony, by the way, will try and get the logs over to you once I’m home from work later :slight_smile: