Mapped recycle bin but Windows says i do not have permission to access

Just like the title says really. I mapped the recycle bin on my MCM via WD Access in the same way i’ve mapped all my shares but when I click on it in File Explorer Windows tells me I don’t have the permission to access it. The same happens when I try and open Recycle bin directly via WD Access. I’ve been searching for a solution for hours but with no luck. Help!!!



Never heard of anyone trying to SMB map a My Cloud Recycle Bin.
It’s not a private share which means it isn’t own by a My Cloud user.
I would guess this to be your problem

1 Like

Being of below average PC knowledge, I assumed mapping was the only way I could see what is in the recycle bin, is there another way?

Map the Share than contains the Recycle Bin.

I don’t have a share containing the recycle bin, which is odd. I think I’m going to do a system only reset and see if it returns. Thanks for all your help.

If you resolve this can you update with a solution please. I’ve never seen or had access to (other than “empty now” in settings) the recycle bin on my MCM.

Same with me but I have read online that it is possible to recover deleted files from the recycle bin by mapping the Share which contains it. I have contacted WD tech support so hopefully will have an answer in a few days

Answer ID 2242 | My Cloud Recycle Bin. This answer explains My Cloud share Recycle Bin file access and permissions… read more.

Answer ID 15062 | Deleted Content Not in the My Cloud Share Recycle Bin. This answer explains why deleted files are not in the My Cloud share Recycle Bin… read more.

Excellent thanks for the pointer. Although the first article doesn’t mention that the information applies to the MyCloudMirror it does works perfectly.

The whole Samba file thing is beyond what i know about Windows. Could some explain the steps i need to access Recycle Bin as I didn’t understand either of those articles. Thanks.

What worked for me - enabled recycle bin for each of my shares. I found that you MUST have deleted something to proceed, if you haven’t then the location doesn’t exist. In Windows Explorer right click and choose add network location. My MCM has the default name so I entered - \\WDMyCloudMirror\Recycle Bin - Volume_1

I have 3 shares and I know that number 1 is called “Camera” so I named the new location “Recycle Bin - Camera” and it works.

If you empty the recycle bin and then try to open it again it will fail as it has ceased to exist.

I couldn’t see a way to restore a file to it’s original location but I was able to play/copy/save to new location a short video that was in there so it’s more of a temporary backup as I see it.

I’ve set the recycle bin to empty automatically after 3 days, enough I think to realise that I want something after all :slightly_smiling_face:

Thanks for your answer. I followed your instructions and successfully created the new network location. When i click on it i get a error message saying Windows won’t allow me to connect as I don’t have the correct permissions.

Only thing that comes to mind is to try setting the share as public with both read and write permission. I didn’t have to add my login details to the NAS. Presumably this is all on the same LAN.