Mapped Drives Gone Wrong


#1

I have one of these beautys and have been impressed so far.I have it attached to a WD USB drive which has been working great also.

I donwloaded and ran WD Discover Tool which helped me map the drive and all was well.

We then had a power cut in the house and it’s all gone wrong!

The media player is still working fine - it is wired into a network and can access the internet. However my PC, running Win7, has a big red X on the drive that was my WDTVLive Hub.

Now when I run WD DIscover, it crashes before it scans anything (The program has stopped working) and I can’t manually add the hub because windows doesn’t seem to detect it.

However, I ran WD Discover on my laptop and it has sucessfully mapped both the WDTV and the USB drive with no problems.

Can anybody suggest any help with a) getting WD Discover to work again (tried installing again etc) and b) getting the 2 drives mapped?

Thanks!


#2

WD Discover is about worthless, in my opinion, and shouldn’t be necessary.

All a Big Red X means is that the drive is disconnected.   USUALLY, double-clicking the drive will re-connect automatically.   What happens if you try that?

Your WD should appear in the LEFT-HAND MENU of the browser, under the NETWORK heading.   (Click the little chevron if necessary to expand the list.)