Major issue with Time Machine and Wireless. WD MyNet N900 and 3TB My Book Live

Hi guys,

I hope someone on here can help me out.  I have a MyNet N900 running 1.05.12 firmware.  Yesterday I bought a 3TB My Book live as something to backup my mac and just have some extra storage.  So today I set the My Book Live up and that all went swimmingly.

Then I tried to backup my mac over wifi using time machine and here is where I ran into a really really strange issue.  Basically when I try to run the backup over WiFi, the backup starts just fine.  After a minute or two the wifi connection completely drops.  The indicator light on the MyNet N900 shows that WiFi is active, and connecting to the router’s administrative page via a wired connection shows that the wifi is active.  However, no device can see, nor connect to the wifi.  The only way to rectify this is to reboot the router.

I saw this thread:

But it does not appear to be related to the issue I am having.  From what I can tell by this thread, the OP is indicating that the mac is losing connection to the drive.  My issue is that wifi completely drops out.  

I should note that I also updated the My Book Live firmware to the latest version as well.  

Any thoughts as to what this could be?

Good to know no one from WD cares.

What firmware versions are you running on the drive and the router?

Make sure that both, the hard drive and the router are up to date.

Please note that this is a user to user forum, is not for WD support.

If both firwares are up to date, try contacting WD Support

Check the link below for the networking support

Both firmwares are up to date.  I even had my router on 1.06.xx before I experienced major issues with that and had to roll it back.  Said firmware has now been pulled by WD.