Mac won't recognise G SPEED Q drive

I tried to connect my G SPEED RAID drive to a friend’s PC - I now know this was a mistake! - and it wasn’t recognised. I’ve since tried to mount it on my iMac (where it was working fine beforehand) and it isn’t recognised and comes up with the message ’ This disk is unreadable by this computer’ and comes up with the option to Initialize the disk. I clicked ignore. The drive wasn’t knowingly reformatted on the PC but could something have happened to the data? This isn’t backed-up and is important. Whta’s the best course of action? Thanks.

If it is asking to be initialized on the Mac side then something was done to the drive on the PC. Just merely attaching it to a PC wouldn’t affect the partition on the drive but if someone had tried to get it to mount by deleting or trying to change partition info it would cause an issue to the drive.

All G-Tech products out of the box are formatted Mac only You can make them work on both but that requires a format change to exFAT. You can attempt to rebuild a corrupted Mac formatted drive on the Mac by using some 3rd party software such as Disk Warrior. That is likely your best option if the data is important.

Paragon HFS+ software was used on the PC for recognising a Mac formatted drive.

Yeah then that wouldn’t affect the partition at all. All that does is allow a Windows PC to read/write to Mac formatted drives.

So will I need to use a data recovery specialist to retrieve the data on the disk?

Mark Hamblin

01479 841547

You could try data recovery software on your own as well. There are many to chose from. Usually you only need to go through a specialist if it is hardware failure. But the fact that it asks to be formatted means it is usually just a software corruption.

If you are certain the drive was never formatted away from its Mac OS format then you can use Disk Warrior to attempt to rebuild the drive.