Mac OS BigSur can't connect to PR2100 login failed

Since upgrading to BigSur I cannot connect to PR2100 via ethernet or router. I see the drive in the locations section of my hardive and when I click ion it to connect it fails after a minute or so. I then hit " Connect as" button and it does the same thing. I have restarted everything and even copied and then deleted all my keychain passwords associated with the PR2100.

Any help or guidance would be appreciated.


I accidentally found a work around. I looked into My Cloud WD web and it could connect to PR1200. I then tried to connect to PR1200 via laptop and it connected automatically as " Guest". Have not seen that before. So I tried the “Connect As” button as I have many times the past two days. It then for the first time asked for login in and PW. Boom connected and now backing with TimeMachine.

Now I need to learn how to update firmware for the first time since purchasing it in July.

Back to Square one. I see the PR2100 on my laptop but it will not connect or ask for password or user name.

Any ideas about why I can’t log in?