Mac not recognising MyBookLive 2TB personal cloud storage

Hello and sorry if this is a topic covered elsewhere - I searched but could not find the answer to my problem in a previous post.

Can anyone help me?

I am trying to set up my new MyBookLive 2TB personal cloud storage drive as a Time Machine for my iMac. The MyBookLive itself is connected properly, I have accessed it through a web interface on my iMac and I;ve even set it up for remote access from my iPhone.

However, I cannot find it in my Finder and my computer does not seem to recognise it when I try to set it up as my Time Machine. I have worked through the instructions as per the PDF manual, but there is no option to connect to the drive in the Time Machine set up process - it’s just not there to see.

I have run the ‘self check’ tool (via the web interface) and it says its working fine.

What am I doing wrong??

Any and all help gratefully received

Hi, be sure to install the latest firmware version. You can also review the steps from the link below for the steps to map the My Book.

Hi there Alucardx and thank you for your reply.

I’ve got the latest Firmware installed (I checked for updates when I got it just a couple of days ago)

I tried mapping the drive, which worked to an extent but I had to log in as a guest because it was not recognising my user name and password. And it didn;t allow me to log in using ‘admin’ and ‘admin’.

When logged in as a guest, I tried to then link it up with Time Machine, but it didn;t recognise that it was there.

Have you any other suggestions that I could try? Thank you for all your help so far - you;ve got me futher than I’ve got before!