Mac - How to delete?

I have some files on the hard drive that i can not delete.  It comes up with an error -50 saying the file is in use.

Any ideas what i can do?

Is there anyway to delete files from the drive other then browsing via finder??

You could login directly into the MBL by using the ssh protocol.

  • open terminal

-type ssh root@IP_ADRESS_OF_MBL

  • enter your password

  • cd /DataVolume/shares

You should see all of your shares now. Just navigate to the directory where the files are you wish to delete.

To delete the file type:

  • rm -R FILENAME

Good luck.

Scatman

Be sure to close any programs that might be using that file and then try again to delete it.

Hi,

I opened terminal … typed the first line with IP address of the drive.  This is what happened:

unknown-e4-ce-8f-16-c9-6a:~ likeafeather$ ssh root@192.168.1.85
ssh: connect to host 192.168.1.85 port 22: Connection refused

Seems to me that you must enable SSH access first.

Do the following:

  • login to your web ui

  • change the url to IP_ADRESS/UI/ssh

  • activate the checkbox for ssh access

  • open ssh shell

  • login with username root and standard password welc0me

  • at first login a message appear that ask you about trusting this connection. You must answer this question with yes.

  • you should be granted access now

  • once on the shell I would change the standard password immediatly via the command passwd

Sorry. i sound a bit thick - but i’m not sure what you mean?   I dont understand the ''change url to IP_ADRESS/UI/ssh??

I am used to windows and not mac - learning lots… but needing it as an idiots guide.  

:slight_smile:

Well, just have a look at the picture below. The screenshot show an excerpt from Mozilla Firefox.

screenshot_ssh.jpg

Thanks for the screen shot.

I have added ssh acces…   now i’m stuck… how do i open ssh?  I cant find this on my mac?

Right… i have worked it out… now i am in ssh and logged into the drive…

What do i need to type in the ssh shell to delete these files?

did a bit more research and i have managed to find commands…

I tried     rm ‘‘filename’’  

Says that there is no such files or directory.

So i am at a loss now.

Ok, lets do this step by step:

  1. Login into your shell (ssh)

  2. Change the directory to your share, e.g. cd /shares/Public

  3. List the files, e.g. ls -l

  4. Navigate to the correct subdirectory, where the file you want to delete is stored, e.g. cd Music

  5. Delete a file with the command rm, e.g. rm nonsens.mp3

If you like to remove a directory add the parameter -R to your command rm, e.g. rm -R Music

You should also make sure that the share on which you would like to delete files is not in use on your PC/Mac.