Mac El Capitan won't recognize My Passport as NAS


I recently upgraded to a new Mac running El Capitan and am having trouble with a WD MyPassport I’d been using as NAS for music files.

I have the MyPassport connected to my Apple AirPort Extreme Time Capsule as an NAS using a USB 2.0 cable. The WD drive contains my iTunes library, so that my Sonos system can access it even when my Mac is asleep or powered down.

This setup worked great for at least a couple of years. But since I moved to the new Mac running El Capitan (I forget which version of OS X I had on the old machine but it was a few steps back) I can rarely get it to work. In Finder I see my network but when I click on it I can only see and access the AirPort Extreme Time Capsule drive (which I use for Time Machine backups). It used to also list, separately, “My Passport.” Now, I can’t see that disk in Finder any longer.

When I go to disk utility, it’s also not listed. In AirPort Utility, when I click “edit Base Station” I do see “My Passport” listed under “Disks” but the option buttons to edit or archive the disk are not present (though I do see these buttons for the Time Capsule disk).

I’ve tried unplugging and re-connecting the USB cable between the AirPort and the WD disk, which doesn’t work. I hear the WD disk attempting to run for a bit when I try to play an iTunes song or when I first re-connect the USB, and the light on the side slowly blinks, but that doesn’t result in the disk actually mounting in Finder. The only thing that has worked, sporadically, is restarting the computer. But the drive doesn’t stay mounted. If I return to the computer after it goes to sleep the WD drive disappears and I have to go through the whole process again.

Any advice on how to fix?

Thanks in advance!


Have you tried resetting the Apple AirPort Extreme? if not, please try that and test mapping the drive again.

When you map the drive, make sure that you select the option to reconnect at logon.

See if this helps