M2TS files not playing on WD TV Live SMP

My Blu Ray movies that are on my HDDs that are M2TS files worked initially on this new WD SMP…the last update a few weeks back zapped them and they won’t play.  They also worked correctly on the WDTV HD LIVE PLUS. 

Anyone else having similar problems…and I am debating whether to spend the long hours converting those files, or wait for a firmware update…

Praying for update!!!

Try the following on the SMP to see if something works:

  • Reset the device

  • Disable Network Share Server

  • Disable Media Library

It worked initially after turning off the network sharing…then I couldn’t get any of them to play after one did, then I restarted the unit, and it started to play them again.


Thanks for the tip.

I had the Media Library feature turned off to start with, because ZERO Movie Thmbnails work when that is turned on, turned off, they all work.

Hope WD fixes some of these bugs soon.  Otherwise this is the best of 4 Media Players I have had. 

Thanks again for the help.