Lost here -- Network share consistently "wrong username/password"

I’ll give the short version:

  • Setup :

– WD Elements 1.5TB drive hooked up to Linksys E4200, NTFS formatted, rights are set as they should be (Everyone Read, Admin Full Control)

– Linksys E4200 setup as “NAS” for that drive

– Drive (it’s basically just movies/series and music) is usable from Mac, Win 7 laptop and desktop

This entire setup worked fine via the Media Player (has network shares added as Media Library), loaded external subs fine. Perfect.

I updated to the latest firmware, and all my network shares (except my Mac itself) disappeared from the WD media player. 

Rebooted the router and media player, got the drives back - but kept on getting Invalid Username/password. 

Did a reset of the Media Player so I could set it up completely again as should be. 

I verified the user account and password by means of :

  • Logging in from a win 7 and Mac; user and password were ok.

  • Tried it again on the media player (with remote and external keyboard); no joy.

  • Reset the password for the drive; no joy

  • Hooked up the drive to a win pc to verify NTFS ACL; was all ok. But on the media player; no joy.

As last resort (you try a 12yo who desperately wants to watch her shows for 3 days); I set up a media server, that works - but loads no external subs. 

Short of remuxing my MKV’s with subs; can someone give me a pointer?

For reference; I actually did rollback the firmware, reset the device, still no joy. Updated firmware again; still no joy. 

Workgroup is correct.

Settings on Media player  https://dl-web.dropbox.com/spa/zxh65nxtnge435l/v96ed43u.PNG

Settings on Router  https://dl-web.dropbox.com/spa/zxh65nxtnge435l/5ifyz5ns.PNG

initial thoughts

you mention both win7 and mac

WD is linux based,

make sure your passwords do not include special characters

like $ # % &    etc …

as for the mac not showing up, I pretty much stay away from macs

but I did hear apple, made some changes to their implementation of smb

which basically makes it incompatible with most non apple products

but I think that was approx 1 year ago, some maybe that has been mostly ironed out

Thanks for your reply :slight_smile:

Perhaps I mistyped, or wasn’t clear. The Mac is actually the one thing that does show up consistently, it won’t work on SMB protocol to connect (obviously), won’t when Linux is enabled, but that’s no issue. The mac is a Macbook, hardly a media server.

I am just desperately trying (I’ve spent 2 full workdays on this by now) to get my WD media player (with latest firmware) to connect successfully to my WD Elements connected via my router (which is also WD coincidentally).

I actually set my password to admin for the shared, to avoid typo’s, special signs etc.

I’m currently resetting my router, the media player, and all ACLs on the drive itself. I don’t have the ability to just format the drive again, don’t have the diskspace for it.


  • I’ve deleted ALL temp files (created by the router) pertaining to ACLs, that seems to have fixed it.

I’ve yet to discover how or why it went wrong. But I’ve logged a support case @ Cisco.

I do apologize for thinking it was the WD player…