Lost connection to Samsung Smart TV

I have a my book live which is less than a year old and two Samsung Smart TV’s.  Everything was working great on my home network until last Saturday apart from some remote access connectivity problems but this was mainly due to JAVA and secuity issues.  However last Sunday morning I lost connection to the My Book Live on my Samsung TV’s.

I have tried everything I can find on the forums, I have checked for firmware updates, restarted the drive, restarted the modem.  I have even upgraded the modem incase the signal was not fast/strong enough.  Still no connection.

Occasionally it shows a connection but as soon as you start to drill down to the folders it disconnects.

The drive works on all my laptops and my mobile phone app.  Other people who have sorted out the connectivity issues I mentioned earlier can see it remotely however my tv’s can’t.

My drive does not seem to have TWONKY, from what I can tell the newer drives don’t so I don’t know where to go from here.  Part of the reason I purchased the drive was to view things on my TV and it isn’t working.  I have raised a call with WD over a week ago and no response so any help would be appreciated.

Thanks in advance

P.S.  I’m not massively technical so please no computer jargon :o)

Do not have a smart TV, but you said…

“The drive works on all my laptops and my mobile phone app.”

If that is the case, concentrate on the TV then, do not worry about restarting or anything else on MBL for now.

Make sure TV is connected to the network, check settings/cables/etc. Also try opening a case with Samsung.


Thanks for the response.

The TV is working fine, its connected to the internet.  I can see the all share of my other laptops on it the USB drivers are working fine and I can see the other hard disks added in.  Firmware is all updated.

It seems to be the My Book Live, it just suddenly stopped working with the TV.  Sometimes it will connect, you can get through to some folders then it disconnects again.

I know others on here have updated the TWONKY but the version I have no longer has this.

I have exactly the same problem with my Samsung TV. All other devices connect to the drive fine. It drops the connection when I do get connected. I suspect it is a router setting but I can’t figure it out. Very frustrating.

OK. I’ve managed to get video playback working again on the Samsung TV.
I downloaded an app for my iPhone called ‘Twonky Beam’. I assume it’s also available for Android.
It takes about 15-20 seconds or so to find the drive on the network, but all photos and videos can be played directly via the app to the TV.
I have played a couple of music videos and they work fine.
One of the problems I had previously was movie playback dropping the connection about 30 minutes in. Having watched the beginning of the same movie twice already, I will need to get in the right frame of mind before I test this again!
Let me know if you have any luck with this.