Lost access via network connection on MacOS

Without any change in my setup, starting the computer today I can’t access my “my cloud home” via the network and being connected as a registered user. Only appears the public and TimeMachineBackup folders.
I can only access my data through the web “home.mycloud.com” but this is not a solution as my software (lightroom) needs to access a drive.
I am running MacOS 10.14.6.
I had the same issue a few months ago when the samba server has been updated. It was solved by clearing the data which by the way made me loose all my photo descriptions and albums I created :confused:
Anyone facing the same situation ?

Hi @odr,

Have you opened a Support Case? If not opened, for more information, please contact the WD Technical Support team for the best assistance and troubleshooting:

Yes I did. It turns out that I needed to clear the device settings once again. Doing so it worked. Problem is that, though it is non destructive on your content it does erase all your albums and descriptions you put on the pictures. As it is the second time this happen, I guess it will happen again, the album and description feature are to my opinion just useless as you will loose them :frowning:

I am having this same issue, and I’ve tried to clear the device setting, but the option is not available for me. I’ve tried different computers (and operating systems), different browsers, the phone app - nothing works. I can log in just fine, the option is just not available. Do you remember how you were able to get to that setting?


I am currently not on the local network where my device is connected so can’t make the complete steps but here it is as I recall :

  • log in to home.mycloud.com account
  • go to parameters from the left side menu
  • go to your device from the left side menu
  • go to manage device from the menu listed on the main window below your device info. The option to reset should be there, it says you need to be on the same local network and that is data non destructive. This is indeed the case, nevertheless experienced 2 times you loose all your albums you have created inside the app as well as all pictures descriptions if you entered some. A real bummer, I lost countless of work hours.

Hope it helps

1 Like

Hello. This is what I encounter, few days after running “Clear Device Settings”.
I have encountered once before… and now the same issue.

Is there any resolution??

WD support avoided answering the subject when I submitted it. Without clear statement who knows if they will tackle the problem or not !

Apple hasn’t updated Mojave since 2021.

18G9323 July 21, 2021 18.7.0
xnu-4903.278.70~1 About the security content of Security Update 2021-005 Security Update 2021-005 (Mojave)

Apple macOS frequently misidentified owner permissions and corrupts files on remote NAS servers if you read the forums from Apple community and some NAS forums such as TrueNAS. Your best bet is to ask Apple for support.


we have now the problem that new files, which are created on the server, do not automatically receive the correct permissions. For example, if I create a new file from an existing Indesign file with “Save it as…”, and then I duplicate it in Mac using “Command + D”, then this copy only receives the write permissions, the file is copied correctly, but the permissions are unfortunately not automatically written to the end, see screenshot: