Liveduo stopped being discoverable

Hello, I recently moved and I’m in a situation where having my own personal router really isn’t necessary. As such, I started using my live duo plugged directly into the ethernet port of my laptop. For the most part this worked fine, I saw it in my Network and was able to map the Public folder as a network drive so I could use it as my itunes library and such.

I say for the most part because maybe one out of five times when trying to access it I would get these messages (depending on whether I tried to access the network location or the mapped drive respectively): Untitled-2.jpg

Very tempermental and intermittent, it was weird I don’t think I was doing anything differently the times when it wasn’t working. Then yesterday it absolutely refused to connect even after restarting the laptop, restarting the drive, and unplugging and plugging back in multiple times. On a lark I turned off my firewall completely and it worked yesterday, now it’s again not working. I just ran that diagnostic tool and this is the report it gave back, I’ll also tell what I’ve tried

besides that.

Ran a WD My Net View diagnostic:

Also installed Quick View:


And WD Discovery:


Again it’s worked before, everything from flawlessly to needing maybe a restart to get it going. Not sure what the issue is, but now I’m getting those error messages from the second image every time. Any help would be appreciated. Thanks.


Have you tried a reset and/or power cycle?