I use the internal 1TB HD of my WDTV Live Hub to store photos & music. I’m only at 1/2 capacity of used space. Recently, I tried adding another album to my Music folder. Because the local internal drive is shared across my network, I can see the folder containing the new album on my desktop pc. However, when I go to the WDTV menu, under Music, the album does not appear. Its in MP3 format, so that’s not an issue. I have some folders with the artist name and inside are subfolders containing the albums by that artist. Suspecting that I “maxed out” the number of folders (which shows 661), I tried moving some of the albums out of their respective Artist’s folder and low-and-behold they are not showing up either. Still showing 661 folders.

I tried changing the Sort by Artist and by Album with no luck. I’m running the most recent version of the firmware and the drive is formatted NTFS, so more than 661 folders should not be a problem. Is there some kind of limitations in the Mocci OS or am I just doing something wrong?

Try turning the media library off and on. It should do and automatic compile. If that does not work try a restart.

Yeah, I tried all that. Restarting, turning it off then on again, even unplugging and plugging it back in again.

One thing I did try after reading your post was I restarted the unit through the Setup Menu and selecting the Restart Device option. It went through the whole “Compiling Media Library” routine, but when it was done, the library remained exactly as it was before. So, if I go to Music, the folders to which I had the artist as the top folder still shows up. As I stated before, I  moved all the albums out of the Artist’s folder, then I deleted the Artist’s folder, so that shouldn’t even be there. I select it anyway and the albums are still in the folder, which I moved. I select an album and try to play a song and it won’t play. It says, “content not found” or something along those lines. Makes sense because I moved it and its not there.

I guess the real problem I’m experiencing is that the Hub is not recompliling the library even though it says it is.  If I restore to factory settings and start over, will it erase the content on the internal drive?

Ok. 1 last last thing you might want to try before doing a full device reset is to do a Clear Media Library. This will do a full compile from scratch. I had the same problem before and doing this worked for me.

1 Like

That seemed to do the trick! All is back in order. I just hope I don’t have to do this everytime I add smething new.