LED problem?

Ok, here’s a new one.  I couldn’t find any mentions of a similar problem.

My MyBookLive has been running OK for several months now.  Other than some initial problems getting the first firmware update, it has been great.

Today I decided to just check the unit physically, and found it with no light at all on the front.

I tried to access some files from it, and it that worked fine.  I tried to start the dashboard from the system tray icon and it failed, but this wasn’t that surprising as I see that more often than not.  I started the UI via the IP address and saw that there was a firmware update available.  So I tried to get that to fire off and it failed.  I tried again and it worked, although it took a long time to complete.  At the end I noticed that the date and time were off by a couple of days.

During the update the LED came on red.  At the end of the update, it went blank.  I rebooted the MBL using the restart option from the dashboard and it seems to work OK, but no LED lights are on.  The date and time updated themselves.

I think that the LED(s) have gone bad.  My theory is that there is a red, blue and green LED and when it was supposed to go “white” all three were supposed to be on.  But if the blue and green LEDs are both dead, then it would have just appeared RED.

I repeat that I have not seen any file problems with the device, and other than having to try the firmware update twice, it’s behaving fine.

I will try shutting it down and doing a full re-power start, but I wondered if anybody here had seen a problem like this?


the HumpMan

An update.  I ran the short diagnostic on the MBL and it passed. I shut it down, unplugged it, waited a few minutes and plugged it back in.

the LED came on RED for a minute or two and then went off.  The MBL is working fine now, but no lights.

This is consistent with my theory that the green and blue LEDs are gone.  On startup, the LED should have been yellow, but if only the red LED is working, then red is what I would see.

Off to contact WD.

WD agreed to an advance replacement RMA and a replacement is on the way.

I have the exact same problem. Just as you described. All functions of the drive seem to work but there is no green status light. It stopped working a few months after I bought the drive. The drive is about 4 months old. I will give them a call to see if the drive can be replaced or serviced.

PS: not sure if the sleep function still works so I will need to test that. Yesterday when I was cleaning the drive I noticed how hot it was so I suspect that it is not shutting down.

I have the same issue.  MBL 2TB version has been working fine for I/O but a couple days ago I noticed there was no green light.  Unit is warm, not hot.  Quickview shows temperature is OK. Dashboard launches and indicates the drive status is ‘good’.  Date and time are correct.  Firmware is up to date.  Short diagnostic test passed.

The drive is less than 3 months old.  I thought LED’s  never failed.  This is the first in my experience.

i have the same problem, my HD also has a blue light but the status of the hd is good , and its working fine, where is the green light??

There may be a hardware issue, and there is definately a firmware OR documentation issue.

Like you, blade, my LED is blue.   Doesn’t switch to GREEN when I access the drive.   It just blinks, blue.

I rebooted the drive, and all three primaries showed up:  RED / BLUE / GREEN, so I know it’s not a LED hardware failure.

I hope they fix this problem soon

Blade3609 wrote:

I hope they fix this problem soon

If everything is working OK what difference does the colour of the LED make. 

the led would indicate a problem, thus i there might be a problem with the firmware or something

Same problem here.  Drive works correctly except no LED light.  It is blank.  On startup it is Red then it stays blank.

WD we need some info if this is hardware failure and a RMA or what?

I am on 1.02.03.

Come on wd we need a response on this issue.

I’m looking into this now.

Our product people are looking into this now. 

Status update please.

2 Weeks now.  What’s the status please?

  I am having the same problem as well. Red LED OK but non Yellow, Green or Blue. I will be contacting WD today to get a replacement ASAP. I also have tried everything from shutting down to rebooting…, and nothing…:angry:

Has there ever been any progress on this issue?  I am having the same problems with the LED lights also. My MBL is about 4 months ago and it worked great. It seems to be backing up files okay, but I am concerned that when I need it, the info won’t be there.

I am using the updated firmware 01.03.03, bit I am curious if the update caused the problems.

This issue should have been fixed with our newest firmware update.

Bill_S if this was fixed then it should have been listed in the release notes.  Since that did not happen then I need to know from a product person what the root cause was and what the fix was before I risk updating my drive and losing my data.