LED light is not on anymore

#5

What you back up to is up to you. Everything that is on my My Cloud is also on my laptop and desktop computers. I also have a lot of it backed up on CD’s and DVD’s. I started yesterday backing up my important data to USB flash drives that I am going to place in my fireproof storage box.

If it is sensitive information that you do not want WD to have you should erase the drive.

cat0w
USA

#6

Thank you. Lucky that the contents are still accessible.

Cheers!

Henry

#7

I’d suggest it is just a faulty LED, if everything else is running properly.

In order to display multiple colours, the front panel indicator is created using either multiple discrete LEDs (yellow, red & blue, AFAICT), or a single, multi-colour led device, incorporating a number of led chips in a single package. Any of these can fail.

‘White’ appears to be implemented by turning on the yellow and blue LEDs. So, if your blue LED has failed, when you turn the MyCloud on, the normal startup sequence flashing white/solid white/solid blue will appear as flashing yellow/solid yellow/no light. Sound familiar?

But if you want to replace your device with a returned drive under the RMA warranty, that’s your choice.

#8

I will add this to cpt_paranoia post. More videos on this, LED’s, can be found doing a Google search. Lab Rat’s had a good one but I don’t remember what episode they talked about LED’s.

cat0w
USA

#9

That reminds me of material science during college time! :sweat:

Henry

#10

If you can still access the file server, the Dashboard, the media server, SSH, do remote access, etc, then I’d say it’s all working bar the LED. You could use Settings/Utilities/System Diagnostics to see if it thinks it is healthy.

1 Like
#11

Thank you for your suggestions. Maybe you are right. Just ignore the LED. I ran System Diagnostics as you suggested. It passed a Quick Test. Full Test is still in progress.

I bought MyCloud in Sep 2014. The computer that I used to set it up was later replaced some months ago. My record shows that I did so with 5 programs, in the following order:

(i) WD MyCloud mc_windows_setup.exe
(ii) WD SmartWare Installer.exe
(iii) WDMyCloud_win.exe
(iv) WD Quick View Setup.exe
(v) WDDiscovery.msi

I also remembered upgrading the firmware sometime ago. It is now v4.04.01-112.

What I found was that without the software mentioned above, MyCloud can be accessed from 4 computers on my home wifi network in 3 ways:

  1. via Network, it shows up under \WDMYCLOUD (except from a laptop running Win 10, a separate issue we’ll deal with later. It was ok previously when running Win 8.1)
  2. via a browser (I use Chrome) under 192.168.1.20/UI/
  3. sign in via the browser under https://files.mycloud.com/

A question: do I really need to install the above software, maybe some, not all? I understand the setup process is different for firmware v4?

Henry

#12

You don’t need any of that software to set the device up, or use it (although WD encourage you to do so, presumably in the belief that helps most users; I’m not convinced it does…). The device can be controlled entirely from the Dashboard, which is built in to the device.

Smartware is an optional backup program, but any other backup program can be used.

The MyCloud desktop app can be used to access the device, but it is generally better to map the device into your computer’s file system, and use the native file manager; windows explorer or Finder.

If you haven’t already, I would recommend you download and read the User Manual.

#13

After more than 5 hours the Full Test just completed. It passed the test!

Thank you for the info on WD software. I’ll happily go without them. I did map a share of MyCloud as a drive on my computer. I found it slowed down boot-up of my computer. So, I removed it later, since I can still easily access it when needed without it being a mapped drive. Moreover, I don’t need it as a mapped drive when running robocopy .cmd scripts to back up my data.

All looks well, except from the Win 10 laptop. It does not show up MyCloud automatically when I click Network, as the other computers (2 desktops running Win 7 & another laptop running Vista) do. It shows up other computers on the wifi network if they are on. However, if I manually key in \WDMYCLOUD in the address bar of Win Explorer it does get connected.

What do I do so that \WDMYCLOUD automatically shows up as well on this Win 10 laptop when I click Network? I need to add that WDMyCloud does show up under Media Devices & Storage categories, but not under Computer whereas it appears in all 3 categories on the other 3 computers.

Thank you.

Henry

P/S: I had indeed downloaded the User Manual 4779-705103.pdf. At first I thought it was the same as the one I had earlier since it bears the same document name. Then I noticed on the very first page that it is for MyCloud with firmware v4. Wonder why WD could not give it a different name to differentiate it from the old one !

#14

When you are in the file explorer on the windows 10 laptop. Click on the refresh icon just to the left of the search network line. ON my laptop running windows 10 this works.

RAC

#15

Read the sticky post on Windows 10 issues at the top of the forum.

#16

[quote=“LimHenry, post:13, topic:145966, full:true”]
All looks well, except from the Win 10 laptop. It does not show up MyCloud automatically when I click Network, as the other computers (2 desktops running Win 7 & another laptop running Vista) do. It shows up other computers on the wifi network if they are on. However, if I manually key in \WDMYCLOUD in the address bar of Win Explorer it does get connected.[/quote]
See the tacked thread at the top of this subforum…

https://community.wd.com/t/compilation-of-windows-10-methods-steps-and-solutions/142576

#17

RAC, I did that several times before. It didn’t help.

Henry

#18

Thank you Bennor for the pointers.

  1. From day 1, my router was set to reserve a static IP address 192.168.1.20 for MyCloud.
  2. From day 1, IP address was also set to the same static address in MyCloud.
  3. I followed Win 10 Specific Method 1 to enable NetBIOS over TCP/IP. Before that it wasn’t enabled. This was the only change I needed to make following the Steps and Solutions.
  4. my home wifi network had already been made to be private network from the beginning.
  5. Network Discovery and File Sharing was one of the areas that I looked into as soon as I had the problem. It was not the cause. Otherwise from the Win 10 laptop I wouldn’t see other computers on the same wifi network.
  6. The refresh button or F5 had been hit many times before.

So far, no luck yet.

I haven’t tried Win 10 Specific Method 6. Must read further before deciding what to do.

As mentioned before, I can connect to MyCloud when I manually type \WDMYCLOUD in the address bar of Win Explorer. It just wouldn’t show up under “computer”.

Cheers!

Henry

#19

I had the same with one Win 10 PC, could reach the My Cloud either by IP address or by specific My Cloud name but it wouldn’t show up under Computer. Using one of the SMB fix options in method 6 worked for me. YMMV.

#20

If you ssh into the My Cloud. There are two files that indicate what the led should currently
be set to.
/sys/class/leds/system_led/color
/sys/class/leds/system_led/blink

You can either cat or more these files. My currently say blue and on.

RAC

PS These are the possible values status is the blink file.
status = on|off|yes|no (yes|no is to control blinking)
color = red|blue|green|yellow|white

#21

I called up Windows PowerShell & put in the Get-SmbConnection command. Yup, it showed only itself & this desktop computer I use to visit this forum. MyCloud was not there. Without doing anything else I closed the command window.

Somehow, not knowing why, I clicked the Network icon after closing the Windows PowrShell window. Lo & behold! WDMYCLOUD showed up under “Computer” category!!! However, when I double clicked the WDMYCLOUD icon, it didn’t go into it. Instead, I got this error message: Network Error Windows cannot access \WDMYCLOUD and so on.

I tried typing in \WDMYCLOUD in the address bar of Win Explorer. This time, it wouldn’t connect to MyCloud. It would before, as mentioned in earlier posts above.

???

Henry

#22

I rebooted the laptop & clicked Network. This time WDMYCLOUD was NOT there anymore. Worse, I couldn’t connect to it at all after manually typing in \WDMYCLOUD.

Will try the “Disable SMB2 & SMB3” option later. What possible side effects are there if SMB2 & SMB3 are disabled?

Henry

#23

Before I went ahead to disable SMB2 & SMB3, for the last time I clicked Network.

MYCLOUD showed up under “Computer”. I clicked it, and, wow ! I was able to go into MyCloud !!! I moved around to see the folders & files there.

Then I closed the window, & rebooted my laptop. All was gone. Back to square one! [big sigh]

I’ll leave things as they are, wait & see if it all comes back.

Henry

#24

UPDATE

After clicking “Network”, with the window showing only the laptop itself & my desktop computer, I decided to leave the window on & walked away.

Guess what happened next?

When I returned after abt an hour, WDMYCLOUD appeared under “Computer” when I refreshed the window. I clicked it, & all the folders in MyCloud showed up !!! I was able to open the folders to see the files inside.

I didn’t disable SMB2 & SMB3. No, did nothing else. And it is ok. Looks like it takes time for the laptop to find MyCloud, then they take time to talk with each other before the laptop wld decide to display MyCloud. How long does it all take? I don’t know. I thought my laptop runs at 1.60 to 2.30 GHz speed. Maybe there’s a timer somewhere?

Anyone has any clue(s)?

Henry