Latest Firmware has a problem on 2nd generation!

I have a 2nd generation My Cloud with the latest update of firmware. After updating to this firmware I have been being asked to sign in with UN and password even though I don’t use a password and was not having to do this prior to the new firmware. Today after signing in and using the dashboard later when I went to use it again I was asked to sign in, after entering my UN and password I was told one of them was not correct. After several attempts and a reboot with another attempt I stopped and ate lunch. When I returned I tried to sign in again with no luck. Finally I tried using just my UN without a password and my dashboard opened. Is this the way this new firmware is suppose to work? Below is an image showing I installed the new firmware on May 23 and the shutdown I made today.


Hello cat0w,

If the My Cloud device has recently been restored or using first time after the setup, the Dashboard Login screen will be displayed with the default values.

  • Username (default = ‘admin’)
  • Password (No password by default)

I believe this is what is happening now. See image below. All I have to do is use my admin name to get back on, no password needed. I have this set for nine minutes.