Laptop can't access MyCloud over Windows network

I have been fighting access problems with MyCloud for quite a while. Just upgraded to OS5 hoping it would help. Now having a problem accessing from my laptop.

I have a small office with the NAS on a network. We have a server - but really no longer need it - I am hoping to eliminate it. The Server and NAS are on the same network. The NAS is set up to use Users through the server or non server users. For the most part this has worked fine since initial setup in April 2018 - with occasional problems logging on - that seem to be self correcting, we really have never nailed down what causes them or how we ‘fix’ them.

I use both my office PC and my laptop at the office. The office PC logs on over a wired network to through the server and generally access to the NAS works well. I connect to the office network with the laptop over a wireless connection. Normally I have the NAS shares mapped to network drives on my laptop, set to reconnect at logon, and they generally work OK. Sometimes they do not and I get ‘Network name not available’ faults. I fight and fight with it, and eventually it reconnects - with no rhyme or reason why.

Decided to update to OS5 today and see if that would help.

Now I cannot log on through my laptop using different users and passwords. I can see the NAS on the network, I can see the shares. When I try to connect or open them, I am asked to enter my credentials. I enter a known good User and Password, and it does not allow me on. It says the ‘User Name or Password is Incorrect’.

I have removed all MyCloudPR4100 credentials from the Credential Manager - no luck.

Since OS5 does not use SMB1, I have disabled it - no luck.

Help!

Mjoelk - thanks for the input.

  1. Not sure what you mean by OS5 being initialized. It is up and running on the NAS and working correctly with 4 office computers and is accessible on internet.
  2. Right now we are not able to access with 2 laptops that are trying to connect with a non server user and password.
    We have 1 desktop and 1 laptop that are able to access the NAS using a non server user and password. We have 2 desktops that are able to access the NAS over the server domain.

when I try to access on my laptop I get the message ‘The specified network password is not correct’ - although it is.

Mjoelk
I just checked the System Log and looked through some others. I do not find anything that seems to relate to this issue. (Or any indications of other issues.)

Just to clarify, I am not having difficulties signing into the Mycloud OS5 site on the web. The problem is signing into the NAS on the network.

So from my playing with OS5 - -

I found that Win10 has a “credential manager”. Credential manager really, really does not like having a single network address or device name with multiple logon authorizations.

For example, If I have a Nas called “MyNas” on 192.162.0.1, with USER1 and USER2 configured… . .
I find that once I log onto 192.162.0.1. as USER1, I can never successfully log on as USER2. The only way I can log on as USER2 is to go into credential manager and wipe out all references to 192.162.0.1. Then, I can log on as USER2. (and can no longer logon as USER1).

There may be a subtlety of credential manager distinguishing between “MyNas” and 192.168.0.1; but I never dug into this aspect.

Yes - Thanks.
I have looked into the Credential Manager but do not think it is the issue. I understand that Windows 10 does not like you to sign into the same resource with different credentials. I have deleted all references to the MyCloudPR4100 NAS in the credential manager - to no avail. Didn’t fix anything.

This issue with Windows has long plagued My Cloud users. One ususally gets a error like this:

Most times its due to trying to use a second (or third) User/Password to access a Private Share on the My Cloud. Windows doesn’t like users using more than one username/password to access Shares on an NAS (for what ever reason). The workaround is to use a My Cloud User that has permission to access all the Shares one wants to access.

One may have to delete all My Cloud entries in the Windows Credentials Manager and remove/delete all mapped My Cloud Shares too. Then reboot the computer to clear certain Username/Password is incorrect errors when accessing a My Cloud Private Share.

Also, if using a computer in a corporate environment the IT department may have set Windows Group Policies that affect NAS Share access. And in rare cases a Microsoft update may have borked NAS access (again). One can see if rolling back that patch update fixes the issue. Finally, as a troubleshooting step disable any third party security/firewall software on the computer to see if that software is affecting access to network devices. In the past users have reported some third party security/firewall software was blocking access to the My Cloud.

Bennor - As mentioned in the thread above, I have removed all related items in the Credentials Manager. - still does not work.

It was not a Microsoft update - the situation occurred after updating the MyCloud to OS5. OS5 cannot be rolled back, but I am stock with it. One of our other laptops today is mysteriously working - it wasn’t working yesterday. We did nothing to correct it.

When I try to map the network drive to the NAS share, I get the Windows security Popup that says that my Password is incorrect.

image

As a troubleshooting step if you haven’t done so already. Check the OS5 My Cloud Dashboard > Settings > Network > Windows Services to see if there is an option called Max SMB Protocol where one can set the maximum SMB version the My Cloud will use. Try using SMB2 or even SMB1 if available and see if that helps anything.

OS5 has been causing a lot of people a variety of problems. As a last resort some are finding ways (in spite of WD claiming one cannot) to downgrade back to OS3 firmware. Such methods are unofficial and may void the My Cloud warranty and depending on the downgrade method used, one’s data may be lost so one should backup their data before attempting a downgrade.

Maybe something like this with NTLMv1 or smb.conf:

and this observation…‘So the real solution was to change the settings on the WD unit itself, in my case it was a PR4100, setting the protocol to NTLMv1 & NTLMv2.’:

1 Like

With OS5, it was originally set at SMB 2 and SMB3. I changed it to allow SMB 1, SMB2 and SMB3. Doesn’t fix anything.

I hate to try reverting back to OS3. Maybe as a last resort, later.

Tekram - This may possibly have solved it - at least for the moment. OS5 was set only for NTLMv2, I changed it to allow NTLMv1 and NTLMv2 and I was immediately able to log in.

I will see if this holds through reboots.

1 Like

OK - This seems to be the solution. I reset the settings to the original NTLMv2 only, and the laptop will not log on. I set it to NTLMv1 and NTLMv2 and I log on immediately, and it survives through a reboot.