Keyboard to sign on to Netflix

Just took my WE TV Live out of the box, hooked it up, updated firmware and am trying to sign on to Netflix…problem, no keyboard comes up and the alpha/numeric keys on the remote do not function like text keys…now what?


after updating firmware do a factory reset:

Setup > System > Device Reset > Reset All Settings Back to Factory Default

if the problem persists … try plugging in a USB Keyboard into the WDTV or even try the WDTV Remote App



1 Like

When I do the reset do I have to eject my external drives and disconnect?

No, that should’nt be necessary …  (a Factory Reset won’t delete your Files)

but if you have any attached USB HDD’s and want to play it safe, then press the “Eject” button on the Remote Control to safely remove them.

When the user id or password box is highlighted (black, I think), just press ‘ok’ and it will go to a keyboard screen.

Rub rad…thanks! Worked perfectly…too simple! feel pretty stupid now!

Joey…thanks for the input. Before I did the reset I tried the simple solution offered by rb and it worked. Appreciate you taking time to help!