Keep Losing Cloud Access

For about the last month or so, I’ve had intermittent problems with cloud access dropping out. Occasionally it will fix itself, but most often I’ve had to reboot the device by pulling the power as the dashboard fails to load too. This seems to fix things for a while, but the issue keeps coming back.

I can access the drive over the local network and the sync software I use doesn’t report any problems either.

As far as I’m aware nothing has changed with my set up and everything has worked fine until as I say about a month ago. The current firmware on my device is 04.05.00-342 which appears to be from October 2019 so I presume that isn’t causing the problem.

The one thing I have noticed is that the content scan stays stuck on rebuilding at 30% on videos.

I’ve had the MyCloud device since 2014 so I’m wondering if perhaps this is an indication of the drive or unit starting to fail?

Is there anything I can check or test to determine if this is a hardware or software issue?

Thanks :slight_smile:

Hi @DigitalBoy,

Please refer to the following KB article: How to run a System Diagnostics Test on a My Cloud

Hi, Neha_07

Thanks for the suggestion. I ran both the quick and full tests a couple of days ago and they passed without any errors. But yesterday, cloud access still dropped out again resulting in a reboot.

Today the content scan status in the Dashboard initially showed ‘Error’. After clicking on ‘Rescan’ and then ‘Rebuild’, it now says Idle but is showing as only 18 pictures found.

Thanks again for your help!

Cloud access issues are frequently due to port forwarding issues with your system. Look at your WD MyCloud dashboard and see if “port forwarding established” or “relay connection established” or “no internet connection”. You shouldn’t need tp rebuild or rescan the DNLA database that often.

Hi @sktn77a,

Thanks for the suggestions. Unfortunately, when the cloud access drops out, I am also unable to reach the dashboard so wouldn’t be able to check if those are an issue.

One thing I can report back on after my previous update is that the Content Scan is still showing as idle with only 18 pictures found. In the Capacity box, it is showing as everything as ‘Other’. Since this happened a few days ago, I haven’t been aware of Cloud or Dashboard access being unavailable once.

In addition to this, as I was planning on purchasing an EX2 Ultra as a replacement if this was indeed the end of the line for my MyCloud, I had a quick look on the forum just to see if anything was happening with them. I noticed a thread with a similar issue to mine that had recently been updated and it seemed to suggest the problem was with indexing from an external USB drive causing the device to run out of RAM.

I don’t have an external USB drive attached to mine, but it does make me wonder if the content scan was/is causing the problem and that would perhaps explain why I haven’t had any issues for the past few days since it decided I only have a few pictures on the device and everything else is ‘other’?