iTunes does not see files in sub-directories


#1

In iTunes, I’m able to see shared music files via WBL shared service ONLY IF THEY’RE PLACED IN THE “SHARED MUSIC” DIRECTORY (i.e. \Public\Shared Music\song.mp3).  

If, however, I place those same files within a sub-directory of the “shared music” folder, iTunes is unable to see them (i.e. \Public\Shared Music\artist\album\song.mp3)

I’ve tried disabling all firewalls and anti-virus, same result.  

I AM able to see the files, in their subdirectories,  via Windows Explorer and incidentally, my PS3 is also able to see them served by MBL within sub-directories.  

Am I missing some setting either in iTunes or MBL dashboard?  

Anyone else run into this and can shed some light?!

Thanks


#2

That’s odd… EVERYTHING I have is in subfolders, and it sees all 3233 MP3s…   

But, I have my music in a private share with Media Sharing enabled.   


#3

I too have media sharing enabled.  The strangest thing the files are visible when placed directly in the “Shared Music” directory, but not in any sub-directory within that.  

Anyone out there who can shed some light on this?  Or anyone else experiencing the same problem?  WD admins?

Help me WD Forums, you’re my only hope!