Issues with WDTV, Issues with registering on support portal, Issues with submitting a support case

Kind of seems to me like Western Digital is falling apart here. Jeez. Anyway… one problem has turned into three…

Original issue that I was trying to put in a support ticket:

Hi all,

Ever since the latest firmware update came out for the WDTV Live (the one that introduces the new desktop tiles), I have been experiencing slow response times to remote button presses, and every once in a while an error popping up on the screen saying that my WDTV is running low on memory, and to reboot it. This error comes up every 2 to 3 days.

I have already tried doing a factory reset and it has not helped. I was never facing these problems before the last firmware update.

Will there be another update soon to address these issues?


  1. Cannot register a new account in support portal

When I try to register I type the ReCaptcha in correctly every single time, but when I click submit the page reloads and at the top it says “Registration was unsuccessful.”     Looking down the page I see no errors being highlighted. I do notice though that when I click Submit the recaptcha immediately loads to a different one, then the page reloads and is back to the original ReCaptcha. This is happening in IE, Firefox, and Chrome.

  1. Cannot submit a support ticket

I found an old WD account so logged in with that one. Filled out the ticket information, go to Submit and I get the following error at the top:

An error was encountered during knowledge base search.

I tried clicking the box next to a few of the knowledge base articles it wants me to say I tried already, but it doesn’t help, still the same error.

Frustrating!   :slight_smile:

I feel your pain on issue 1. I’m surprised you get 2 to 3 days, as I was getting a couple of hours max. Also complete lock-ups as well as the slow down and out of memory warning issue.

I actually got an email from the support guys after I posted a couple of times here and they said to try a reset as that fixed ‘most’ of the issues. I did that and left the device running, a few hours later, came back and it was locked up on sthe screen saver. Obviously the issue(s) not fixed are the ones that stop the device really working.

The only recourse is to rollback your firmware. There’s instructions and links to download the rollback zip on this forum. It works well and your WD will be back to its old flaky self rather than non-functioning. Then we wait for the actually fixed version, I guess!

I too am having the same issue when trying to log a support case “An error was encountered during knowledge base search” whats the deal and what’s the bloody point of it all if you cannot log a support case because of this dumb error?