Issues with WD My Passport & my Mac Pro

I picked up a 1TB My passport to backup mov. files.  I have a mac pro with OSX 10.5.8 (intel based) … I partitioned the drive - selected GUID - and loaded the files.  Then, when trying to access them I am stonewalled by a “device removal error” message that says “the device was put away improperly” - which isn’t the case - I’ve never ejected it improperly.  Then it disappears from the desktop.  I can reconnect it - and it appears temporarily - until i try to use it - then it errors again and disappears.

The kicker is, the same thing happened on the same computer with a different (brand new) 500G My Passport previously.  I compiled some files for a family member and had the same result.  I bought another WD HD thinking it was an anomaly.  I’ve tried re-partitioning the drive with no success.  A very nice rep tried to help me on the phone - but his suggestion of repartitioning and clicking the GUID checkbox didn’t work. 

I’ve tried everything i can think of - the cable is perfect, i re-formatted multiple times and tried different USB ports…

I’m absolutely stumped.  Thanks for anything forum dwellers!!

There’s one thing that you can try, you can download the WD turbo drivers from the wd website to see if that fix your issue. Since is not the first drive that does that to you, it might be a driver issue on the computer.

Link to download the turbo drivers

Have you tried with a different computer?

1 Like

Thanks for reading my post!  I will try that.  It does work on my wife’s mac computer (newer-intel) - no problem - but not my mac pro which is obviously my preference.  I’m positive it has something to do with my computer specifically since this is the second WD HD that i’ve had this issue with.  Installing/replacing drivers is beyond my level of expertise, so i’ll ask for some more advice.  In the meantime, thank you for your thoughtful post!