Issues with dropbox sync - Dropbox 2.00

Hi Support,

I have been facing a lot of issues with dropbox sync lately. Dropbox stopped working in my WD Mycloud EX2100. As the inbuilt appstore was also not showing any apps, i manually downloaded and updated dropbox to the latest version ‘Dropbox 2.00’. Two issues i face are;

1). I am not able to selectively sync folders using the WD Dropbox app. It used to work before, but now it does not load the folders in my dropbox account.

2). My dropbox sync fails and below error is shown in mycloud admin console.

‘Unable to connect to Dropbox. Please restart your system and try again. If problem remains, try re-install the Dropbox app’.

I have tried restarting the device and results in the same error. Please help to sort out this issue.

My Ex2100 is running the latest firmware ‘2.30.165’.

Hello mhameed,

Previously there were no issue using DropBox with our My Cloud device. However, currently Dropbox is not supported with My Cloud devices due to which Dropbox 2.00 is not available to be updated through the dashboard of your device.

Also, we don’t recommend manually updating the Dropbox 2.00 as it’s not still compatible to be used with our My Cloud device.

If possible uninstall the 2.00 version and install the old version.

Dear Logan,

Below is the official 3rd party apps link provided by mycloud for Ex2100. If you parse the XML file, the dropbox version available for Ex2100 is Dropbox 2.00. Also i was experiencing above issues with the old version of dropbox app (1.10) which is why i manually updated to the latest version expecting all these issues to be resolved.

http://download.wdc.com/apps/WDMyCloudEX2100/WDMyCloudEX2100.xml

Hello mhameed,

Maybe you should try contacting WD’s Technical Support about this.

To Contact WD for Technical Support

I did open a ticket with WD 3 days back. I am yet to receive a reply. :confused:

I am getting this error too mhameed. Please let me know if you figure it out.

Hello there,

The firmware of your device is too old. Please follow below KBA and update the firmware, then check the issue if it still persist, make sure to use second KBA which explains how to add Google DNS on your device.
The latest Firmware for your device is 2.31.195.

1- [How to Auto Update Firmware on a My Cloud]
https://support-en.wd.com/app/answers/detail/a_id/6546

2- [How to Use Google public DNS servers on a My Cloud]
https://support-en.wd.com/app/answers/detail/a_id/16487/