Issue with MKV FF/RW: MakeMKV and mkvtoolnix/mkvmerge


#1

SO! - I found out something which maybe a lot of others have discovered, and maybe this can help WD resolving the irritating MKV FF/RW problem where mkv movies can not be FF/RW’d without jumping back, and chapters does not work. BTW this problem is NOT resolved with firmware 1.01.24.

I have a lot of series on DVD, e.g. Charmed (Well- just mock me ;o)

I have converted these Charmed DVD’s to an ISO image pr. DVD, and then used MakeMKV to separate each ISO image into chapters. These do play on WD TV Live, but FF/RW and chapters do not work.

Then I tried taking the mkv file made by MakeMKV, and sent it through the mkvmerge tool from mkvtoolnix with the simple command ‘mkvmerge -o outfile.mkv infile.mkv’. This should not recode the audio/video streadm in the mkv container at all, and is indeed very fast. This SOLVED the problem. the file now plays on WD TV Live, FF/RW and chapters work.

There is one catch, however. It seems that the video output of the WD TV Live is “resetting” ?? when starting to play the mkvmerge mkv file. It takes 4 seconds longer to start this compared to the makemkv file.

My guess: mkvmerge corrects some meta/header information that maby has been set up erroneously by makemkv? Or WD TV Live is not fully compatible with the MKV container format?

Any comments?