Issue playing AVI and MP4A on Samsung TV and PS3

Hi All,

Relatively new to using a NAS so hoping someone with more expertise can help! I have set up the drive and moved all my photos and music across without any problems. Everything plays thorugh my laptop great. The issue arises when I try to play any AVI files or any music from the Itunes folder (MP4A format) on either my Samsung TV or PS3. Both see the files fine but give a ‘format not supported’ error. Now I have played the same files on both via PS3 media server and also via USB stick without issues so the files are sound. As soon as I try to play via the NAS it’s a no go! 

I have tried the renaming trick on the AVI file with no joy. I have the latest firmware and have tried switching from Twonly to the WD media server and again no joy.



Some compatibility problems might happen when streaming files. Have you tried to play other extensions to verify if the same  problems keeps happening? 

Thanks for the reply but all other extensions such as mp3 and various other movies play fine. It is just the mp4a and Abi files that are not playing. Both the ps3 and tv support these and they play fine off a memory stick or via ps3 media server just not via the mybooklive?

You might also want to download the latest firmware available so you can try the latest DLNA server.

How to update the firmware on a My Book Live or My Book Live Duo