Is it possibe to have a small Web Server on My Cloud?

I know apache2 is installed but not configured, and I also read on another post that reloading the new apache2 config file generates error message due to UI / Dashboard issue. Now I am wondering about the nginx and bind9, could they be installed and used since they are very light weight and easy to work with. Have anyone done this before? Appreciate your input.

Hello there,

I have not tried this, lets see if another user can share some information or tips on this matter.

I’m running wordpress and owncloud plus few other sites on MyCloud 4TB single drive v4 firmware, Nginx+PHP7-FPM+Perl-FGCI+MySQL. Look for my webhosting mods thread :wink:

Thanks for your reply, if you would, please post your Apache2 config file. I need a step by step to follow. Apache2 server is running fine, the site under Public share (WWW) has been enabled (a2ensite …) but when I run “service apache2 reload” to activate the new configuration I get error message saying "Listen cannot occur within “VirtualHost” section …
I have the same setup for Apache2 running on my Ubuntu 14.04 laptop and it works great. Duplicating it to My Cloud causes this issue… Any idea?

Thanks ArMak for your reply, lets hope someone send us a step by step instructions… I don’t believe it is doable after v4 firmware. I like to duplicate my Nginx and Bind9 setup which I am running on my Ubuntu 14.04 to My Cloud (2GB).

I’ve stopped using Apache2, my Apache2 config file is now per WD’s default untouched. IIRC you need to setup in the conf.d instead because of WD’s settings. Also if you do this you also need to include all WD’s config file e.g. the rewrites else the Dashboard will break.

What kind of sites you’re running on the Ubuntu that you want to migrate to MyCloud? And why do you need Bind9? You can run virtualhosts without Bind9. I suggest you switch to Nginx altogether, refer to my mods here: [APP] WebHosting for firmware V4+ (10/2015)

I have been running Nginx along with Bind9 on Ubuntu server for several
years now. Bind9 is for DNS and Zone handling and it does a great job.
I agree with you as far as not running the Apache server on WD. I am
looking at few other options including getting a Raspberry Pi since it is
the most common way these days for running a lightweight Web server or
possibly switching to a different NAS.

I skipped Raspberry Pi because it doesn’t have gigabit port, may be you could take a look at Banana Pi it has gigabit port.

For me at the moment, MyCloud is my best choice for both NAS (quite affordable + surprisingly fast transfers compared to other lower end NAS) and web server (after few mods to run Nginx and FastCGI apps).

If you like, you could downgrade to firmware v3 for more flexibilities e.g. install Bind9 or build the apps you need for v4 firmware or install other firmware provided by a user here fox_exe. Though I still stick with the v4 firmware due to the transfer speed.

Thank you Nazar78 , I will look at Banana Pi.
For now I run my Nginx server from Ubuntu machine till I get a good set of
instructions on how to run Nginx from My Cloud. BTW, no intention of
lowering my firmware version at this time.
I did talk to Western Digital level 2 support engineers and unfortunately
they had no knowledge of such a thing like Nginx, etc…

Go to the forum thread I provided earlier, follow the simple steps to run my installer and you’ll have Nginx ready at your disposal :stuck_out_tongue: Note Nginx is running on port 5080 as not to conflict with Apache2 (WD’s Dashboard). The installer will also switch Apache2’s mod_php5 to php5-fpm to be shared with Nginx. JFYI my installers are running on MyCloud 4TB itself :slightly_smiling:

No comments on that :stuck_out_tongue: