Is it just my unit or every SMP?

I’ve had nonstop problems with the SMP for over a month now since i brought it as a birthday present for my dad.

Basically it constantly gives me errors like invalid login details, unable to connect to share, no media in the folder and a lot more.

It worked reasonable well (aside from a little messing around required to get it to work) for the first week we had it, but it’s become increasingly worse.

What i’ve tried:

-Renaming all the computers on the network to lowercase single words less than 8 characters

-Disabling of all firewalls and passwords on all the computers in my house

-Upgrading firmware

-Resetting the SMP to factory defaults

-Resetting the router to factory defaults

I have 3 main computers which have shares on them. 2 WinXP and 1 Win7. After countless hours of troubleshooting and various fixes found on the forums, this is what my problem is currently:

When i try to connect to:

Windows XP (sisters): Invalid username or password error

Windows 7: No media in folder

Windows XP (mothers): Has the exact same settings and operating system (might be a little out of date) as the top one (my sisters) and displays the movie fine (the same movie as what i have on the Windows 7)

This all used to work reasonably well, and all my computers can connect to eachother without a problem.

I plan on returning it asap, i just wanted to know if i should ask for store credit instead of a replacement.

You might want to contact support before ruling the unit as faulty…

Most of the times when you get prompted for passwords it works by entering the user name and password for the computer you are connecting to…  Not the internet or router password

As i had mentioned in my post: the passwords on every computer in the house were removed.

One of the windows xp computers allowed an anonymous login, but it gave an error on the other one with the same exact settings.

Upon replacing the device i no longer had any problems with the passwords. However i still have the “No media in folder” error on my windows 7 computer.

And just to reiterate, i have the same exact files on the other computers and they stream just fine.

Would you happen to have a link to contact support?


You’ve probably have tried this already, but first the computer has to indicate the drive as sharing;  you have to go to advanced sharing to set up your computer to be capable of sharing.  Then I was running into all kinds of problems after I had set up the drive and my computer to sharing.  I then realized that I had to go to Security and set it for “Everyone” to be able to read and write.  That way the SMP can compile the media library and the SMP can access the files.

So first the computer has to be set up and one does that through advanced sharing.

Then the particular drive has to be set up for sharing.

Then the security has to be set for that drive for “everyone” to be able to access it and read and write.

(I guess one can set it to read only if you don’t want to compile the media library with covers, etc. ??)

There probably is a better explanation of this already on this site, and if you want to be very technical, you can do a search on the MS site if you’re running Windows 7 or I guess one can google the step by step process.

Hope this might through some light on the problem.

Yeah i’ve already tried setting the shared folder’s access to read and write for everyone in advanced sharing.

Things are getting a little weird now though, i tried enabling public folders in windows 7 and it showed an old test folder in the SMP but not the new one. Not to mention i can’t stop sharing the old folder because the checkbox for sharing is unchecked but it says that it’s shared.

Heres a screenshot of the settings for the new test folder.

Is there a way to reset all my networking settings to default? I think i might have messed something up somewhere.


FYI i think you do need passwords on accounts otherwise it will fail. No password doesn’t mean anonymous. You will either need to activate the “Guest” account which is annon or set passwords and use em.

In Windows 7 i think you’ll need to turn off higher security under sharing where it uses 128bit vs 40bit. In that screenshot you showed, go to “Permissions” and it’ll show X user with read only perms. See if you can add “Everyone” and that might help if it’s not already set to that.