iPhone App - Error Uploading 1 File

Hey so I’ve recently purchased the My Cloud Home and was interested in getting the iPhone App working; so far I’ve managed to sync up all my other devices except the iPhone App.

So, the error I’m getting is “Error uploading 1 file” when I attempt to upload an image directly from the iPhone App. It doesn’t seem to be automatically uploading my camera roll in the background either as I’ve had a rather large amount of images on the notification bubble.

On the settings, the colour circle flicks between red and green depending on if I’ve tried to upload, and I’m a bit lost as what to do next…

So far I’ve tried reinstalling the app, resetting the entire My Cloud Home device and disconnecting / resetting my internet, none of these have worked.

Literally any help would be appreciated! :slight_smile:

@stuartajd Can you send us your mobile app and My Cloud Home system logs please?


@SBrown Thanks for the reply! I’ve sent both the logs under the same addresses as my account here.

My support case: #091917-12329510

:slight_smile:

Thanks Stuart,

We’ve forward the logs to engineering.

1 Like

Please keep this thread updated. I purchased the My cloud Home today and am experiencing the same issue with my wife’s iphone.

@ASigstad Can you send use the mobile app and system logs please?

i am having the same issue. i have already spent the best part of 3 hours talking to your team members trying to solve this issue and still nothing. I have too sent me logs… my case ref is 091517-12320332
Just so you guys know I’m using 2 iPhones and a iPad and none of them will let you upload through your app…However if i go onto safari on the iPhone or iPad and go the the mycloud webpage then i can upload pictures from my phones or iPad that way.
other issues I’m having is when i log into the mycloud web page it shows straight away that my device is offline so i have to click through a few tabs before it shows its online or any files show up.

It only allows me to sync folders that are on my desktop! (I’m using a mac)

Ive done a time machine backup but can’t actually see this anywhere in mycloud device! is this right?

And the last thing is that even when I’m not using the drive for several hours i can still hear the drive as if it is uploading or doing something. This is very annoying… is there a fix for this to make it go into a sleep mode.

Im on the verge of taking this back to the shop so please reply fast!

@clarksta
ISSUE #1 iOS File Upload
The mobile app issue has been reported to engineering and they are working on it.
I’ll add your logs as well.

ISSUE #2 Offline
This issue almost sounds like browser cache or a momentary network connection issue.
Do you logout of mycloud.com and log back in or just close the browser and open it again when the offline message occurs?

ISSUE #3 Time Machine Backup
Time Machine backups are not accessible from the web, mobile and desktop app, but can be accessed through Finder and will reside in the TimeMachineBackup local share.

ISSUE #4 Indexing
When the content is added to the My Cloud Home, the data is catalogs, indexed and thumbnails generated.
This process can only be stopped by powering off the device, but will start again once powered on

QUESTION: What is the routers make and model? Who is your ISP? it will help with troubleshooting connectivity issues if there are any.

issue 1… OK Thanks

Issue 2… Basically when i log into the web browser straight away down the bottom left it says the device is offline. I then have to navigate through tabs for it to come online but if left for a while it will go offline again.

Issue 3… i don’t understand what you mean… The way i have done time machine backup is by opening Time Machine preferences then selecting the mycloud device and thats it. Are you telling me thats the wrong way to do it?

Issue 4… I thought the idea of this device was so i can leave it on and access it anytime but from what your telling me is that unless i turn the device off i will always hear it making enjoying noises like its backing up something. I can’t even read a book in my front room now because of how distracting this can be!

Answer to your question is I’m with BT Infinity fibre Broadband and i have a BT Hub5. I don’t know much about ISP but i just googled it and its saying it 86.150.89.203

So you know i have gone into my hub settings and allowed the myclouds device ip address to bypass the firewall and i have also tried turning off upnp too and none of this has worked.

Yes it is designed to be on 24/7

But it makes noises as if it is working on something even when not being used. Think i will take this item back as I’m having nothing but trouble with it.

once indexing the content is done it should stop making noise when it is not in use.

this is my point… there is hardly anything on the drive and it makes noises like its working all the time!!

Hey, just wanted to add a quick note, I’ve just installed My Cloud Home on iOS 11 8 Plus and it works, so possibly just an iPhone 6 issue? Not too sure. I tried it on iOS 10 and iOS 11 on the 6 and didn’t work.

Just wanted to let you know! :slight_smile:

@stuartajd Are you in the UK Time Zone?
If so, trying changing the zone from the iOS default of 12 Hours to AM/PM and let us know if the Error
Uploading 1 File is still there.

1 Like

Hello this fixed the problem for uploading from IOS app. I had to turn off set automatically then turn on 24-hour.
Will there be a fix for this as I don’t want to keep the settings like this.
Also now the issue with the web browser saying I’m offline is to do with safari because if I use chrome on my Mac I don’t get this problem. Again will there be a fix for this?
My other main issue now the drive constantly marking a noise as if it’s is backing up or uploading something even when nothing is on the drive or even if there is only 1 photo on the drive.

Also can you tell me if I’m the future there will be an option to plug in an external hard drive and back up MyCloud Home device like you can do on your older generation devices?

Look forward to your reply!

Now that it uploads from a iOS app every time I upload something I get a text file (that I can’t even open) show up every time.

This is all very disappointing having all these problems. For £310 I don’t think this is worth it and think I’ll be taking it back to the shop :pensive:

Are you referring to the HEIC file? If so this is the new image format introduced by apple in iOS 11. This file format is the default for iOS 11. It is not yet supported by the MCH apps. you can change the format settings for the iOS 11 camera to most compatible. see the knowledge base article on the WD support site below.

My Cloud Home iOS 11 Camera Support for HEIC and HEIF Format

Yes that’s what I was on about. But why is it there. If I upload 1 picture it will upload the picture and that added file.

And can you answer the other questions about the mycloud device always making hard drive noises as if it’s working on something even if the drive is empty or if I have not used it for days.

And the questions about if the problems will get fixed and if the external back up option will become available soon?

if you have not changed the camera format setting the camera will take all pictures in the HEIC format. in your screenshot I see the other images are named GPTempDownload_x.jpg. That is not a default name for images in iOS. Have you used some other app to filter, crop, or some way edit the pictures? iOS images naming is IMG_XXXX.HEIC etc.

If you do not want the HIEC formats follow the directions in my post above to change the camera image format and all your pictures will be in jpeg format.

Not sure on this one. I do not notice this with the My Cloud Home Duo I have but it sets in my living room behind the TV where it is pretty loud most of the time. Maybe someone from WD Staff can comment.