Ip address problem mybook

My older MyBook worked perfectly until I got a new router two days ago. The ip address, after the correct numbers are shown,  ends with “(Public)” and although I thought that odd, it worked normally with that name after the ip address. Now, with this new router that drive shows up in ‘my computer’ as a drive but it can’t be found on my network. Trouble shooting through the various network help (windows7) it can’t be found but within the trouble shooter it found the correct ip address but the error seems to be the wording (Public).

The trouble shooter asked if I had spelled ‘Public’ correctly so I’m assuming it is that that is causing my problem. I hoped I could change the ip to the correct address without that evil word, Public. Seems not, so far and I am concerned about losing any data before I can move it to the new. My new 3T dtrive will arrive either today or tomorrow and I am anxious to get the old one ready for tranfer to the new. Help is requested. Toolkit, anyone?

Have you tried a device reset?