Invalid username and password

OK there has to be something wrong in regards to WD and the username , password. I continue to get invalid username or password when I try to access my windows shares. I have enabled full sharing within windows and WD shows in network. Password protection is disabled in Win 7 and all my other computers have no problem accesssing the shares. Except for the WD that one day accepts “anonymous” username and “blank” password and the next says that is invalid. No longer can I access the shares within my network and deemed this unit useless other than a netflix box. Seems to have started occuring when I intalled the alst update.

Any help would be appreciated as I really dont want to return it but no point in keeping if it continues to do this. Also suddenly can no longer play avi files when I was actually able to access my content (no sound and stutters)

Im on wired using the WD livewire

 tried power cycling with no luck

Have you tried clearing the stored credential information for the share and readding it? Setup -> Network Settings -> Clear Login …

nope that didnt work either thanks for trying though I appreciate it

wow who would think it would be such a trying thing to get the shares working.

For the login issue, i found the best solution is to just enter the name of the computer’s user account (rather than anonymous) and then save it.

No idea about the AVI issue, but i had a similar issue over wireless (no sound and stuttering) that was fixed in one of the previous firmwares.